TMO WE826 and MC7455 Slow

Related to Router Devices ONLY
jmattivi
Posts: 6
Joined: Mon Jan 07, 2019 10:10 pm

TMO WE826 and MC7455 Slow

Post by jmattivi » Tue Jan 08, 2019 11:32 am

Hello,

I've seen a couple other posts referencing slowness (0.2 avg down), but on other networks besides TMO.

I tested the sim in my phone and got 22 down, it consistently is below 1 down in the 826.

This is a brand new setup and followed the tutorials and troubleshooting.

I know the signal isn't great, but again the phone gets 22 down.

Any help or pointers is appreciated!
Thanks!!

Code: Select all

at!gstatus?
!GSTATUS: 
Current Time:  505		Temperature: 34
Reset Counter: 2		Mode:        ONLINE         
System mode:   LTE        	PS state:    Attached     
LTE band:      B4     		LTE bw:      20 MHz  
LTE Rx chan:   2250		LTE Tx chan: 20250
LTE CA state:  NOT ASSIGNED
EMM state:     Registered     	Normal Service 
RRC state:     RRC Connected  
IMS reg state: No Srv  		

PCC RxM RSSI:  -85		RSRP (dBm):  -113
PCC RxD RSSI:  -86		RSRP (dBm):  -111
Tx Power:      0		TAC:         56EB (22251)
RSRQ (dB):     -8.8		Cell ID:     00D7F002 (14151682)

swwifty
Posts: 158
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: TMO WE826 and MC7455 Slow

Post by swwifty » Tue Jan 08, 2019 12:14 pm

What is your SINR? Should be the last line from the gstatus output, looks like it got cut off?

Are you testing indoors/outdoors? I'd recommend trying outdoors. B4 is gonna have a hard time penetrating your house.

jmattivi
Posts: 6
Joined: Mon Jan 07, 2019 10:10 pm

Re: TMO WE826 and MC7455 Slow

Post by jmattivi » Tue Jan 08, 2019 1:01 pm

sorry, was waiting for the post to approve and forgot these details....

firmware: GoldenOrb_2017-12-15

Wireless is disabled and connection for speed test is wired.

The router is currently indoors. I do have an outdoor antenna to connect, but am waiting on the cable/connectors. I just expected the download to be similar to that on the phone of 22 down rather than <500kb.

here's the full output.

Code: Select all

at!gstatus?
!GSTATUS: 
Current Time:  2999		Temperature: 34
Reset Counter: 1		Mode:        ONLINE         
System mode:   LTE        	PS state:    Attached     
LTE band:      B4     		LTE bw:      20 MHz  
LTE Rx chan:   2250		LTE Tx chan: 20250
LTE CA state:  NOT ASSIGNED
EMM state:     Registered     	Normal Service 
RRC state:     RRC Connected  
IMS reg state: No Srv  		

PCC RxM RSSI:  -83		RSRP (dBm):  -110
PCC RxD RSSI:  -86		RSRP (dBm):  -112
Tx Power:      0		TAC:         56EB (22251)
RSRQ (dB):     -10.3		Cell ID:     00D7F002 (14151682)
SINR (dB):      5.4

User avatar
JimHelms
Site Admin
Posts: 362
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: TMO WE826 and MC7455 Slow

Post by JimHelms » Tue Jan 08, 2019 1:13 pm

jmattivi wrote:
Tue Jan 08, 2019 1:01 pm

firmware: GoldenOrb_2017-12-15
Download and use this newer version of GoldenOrb.

First, remove SIM CARD.

Be sure and UNCHECK the SAVE SETTINGS box.

Once it is loaded, set your APN, TIME ZONE and PASSWORD.

Then go to NETWORK > FIREWALL > CUSTOM TTL SETTINGS and ENABLE for Value 65. SAVE & APPLY

Unplug power and wait a few seconds then power it back up.

See if that helps.

swwifty
Posts: 158
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: TMO WE826 and MC7455 Slow

Post by swwifty » Tue Jan 08, 2019 1:33 pm

jmattivi wrote:
Tue Jan 08, 2019 1:01 pm
sorry, was waiting for the post to approve and forgot these details....

firmware: GoldenOrb_2017-12-15

Wireless is disabled and connection for speed test is wired.

The router is currently indoors. I do have an outdoor antenna to connect, but am waiting on the cable/connectors. I just expected the download to be similar to that on the phone of 22 down rather than <500kb.

here's the full output.

Code: Select all

at!gstatus?
!GSTATUS: 
Current Time:  2999		Temperature: 34
Reset Counter: 1		Mode:        ONLINE         
System mode:   LTE        	PS state:    Attached     
LTE band:      B4     		LTE bw:      20 MHz  
LTE Rx chan:   2250		LTE Tx chan: 20250
LTE CA state:  NOT ASSIGNED
EMM state:     Registered     	Normal Service 
RRC state:     RRC Connected  
IMS reg state: No Srv  		

PCC RxM RSSI:  -83		RSRP (dBm):  -110
PCC RxD RSSI:  -86		RSRP (dBm):  -112
Tx Power:      0		TAC:         56EB (22251)
RSRQ (dB):     -10.3		Cell ID:     00D7F002 (14151682)
SINR (dB):      5.4
Based on those signal stats, and my experience with (band 2 on AT&T) you should have a pretty good signal boost just going outside with the same antennas, and even better with external dedicated antennas.

Hopefully that translates to faster downloads for you, and the tower is not congested.

I'd suggest following Jim's advice, hopefully that can sort out your odd issue.

jmattivi
Posts: 6
Joined: Mon Jan 07, 2019 10:10 pm

Re: TMO WE826 and MC7455 Slow

Post by jmattivi » Tue Jan 08, 2019 2:34 pm

Thanks!!!! I wasn't optimistic, but the wifix firmware did the trick!

I'm now getting ~15 down....beats 0.1. Hopefully once the antenna is hooked up, I'll be sitting good at that point.

Thanks again!

swwifty
Posts: 158
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: TMO WE826 and MC7455 Slow

Post by swwifty » Tue Jan 08, 2019 6:41 pm

jmattivi wrote:
Tue Jan 08, 2019 2:34 pm
Thanks!!!! I wasn't optimistic, but the wifix firmware did the trick!

I'm now getting ~15 down....beats 0.1. Hopefully once the antenna is hooked up, I'll be sitting good at that point.

Thanks again!
what outdoor antennas did you get?

jmattivi
Posts: 6
Joined: Mon Jan 07, 2019 10:10 pm

Re: TMO WE826 and MC7455 Slow

Post by jmattivi » Thu Jan 10, 2019 10:03 am


User avatar
JimHelms
Site Admin
Posts: 362
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: TMO WE826 and MC7455 Slow

Post by JimHelms » Thu Jan 10, 2019 11:28 am

jmattivi wrote:
Thu Jan 10, 2019 10:03 am
i have one of these

https://ltefix.com/shop/antennas/700-27 ... l-antenna/
If you are using only one antenna, make sure it is hooked to the LTE antenna that goes to the MAIN antenna connector port on the MC7455.

jmattivi
Posts: 6
Joined: Mon Jan 07, 2019 10:10 pm

Re: TMO WE826 and MC7455 Slow

Post by jmattivi » Thu Jan 10, 2019 11:48 am

Thanks for the heads up!

Still averaging ~ 10 down/1 up right now with the router in the basement (currently locked on band 4). Will post back the results of setting the external antenna up outside.

Post Reply