Airmaster 4000D Not pulling in tower signal on verified band 41

Related to Router Devices ONLY
Forum rules
Use the SEARCH function for related issues PRIOR to posting for assistance.
417linux
Posts: 7
Joined: Tue Jan 07, 2020 10:21 am
Has thanked: 0
Been thanked: 1 time

Airmaster 4000D Not pulling in tower signal on verified band 41

Post by 417linux » Tue Jan 07, 2020 10:29 am

I just purchased the Airmaster 4000D and I'm unable to get this to receive a signal from the tower. I've verified band 41, tried multiple CAT6a cables and factory reset a few times. Connected with the POE injector and with a POE switch, it will power on the unit and I can log in through the gateway however it doesn't seem to power on the modem. My normal franklin hotspot pulls in a decent signal. Anything else I should try? Is there a recent firmware update for this device?

User avatar
JimHelms
Site Admin
Posts: 1292
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Has thanked: 77 times
Been thanked: 168 times
Contact:

Re: Airmaster 4000D Not pulling in tower signal on verified band 41

Post by JimHelms » Tue Jan 07, 2020 1:21 pm

Does it show that the SIM Card is ready, in other words, is it reading the SIM Card okay?

417linux
Posts: 7
Joined: Tue Jan 07, 2020 10:21 am
Has thanked: 0
Been thanked: 1 time

Re: Airmaster 4000D Not pulling in tower signal on verified band 41

Post by 417linux » Tue Jan 07, 2020 1:37 pm

Yes, it says the sim card is ready, I have also tried taking it out and powering it up to see if the radio information populates.

417linux
Posts: 7
Joined: Tue Jan 07, 2020 10:21 am
Has thanked: 0
Been thanked: 1 time

Re: Airmaster 4000D Not pulling in tower signal on verified band 41

Post by 417linux » Tue Jan 07, 2020 1:41 pm

On the Franklin router under debug info it says MCC 310 and MNC 120 / Band 41.

User avatar
JimHelms
Site Admin
Posts: 1292
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Has thanked: 77 times
Been thanked: 168 times
Contact:

Re: Airmaster 4000D Not pulling in tower signal on verified band 41

Post by JimHelms » Tue Jan 07, 2020 1:49 pm

While the SIM Card is in the hotspot try to update the User Profile and any other updates available. Then, remove the SIM card and reinstall in the Airmaster.

Someone on another post mentioned having to do this before it would connect.

417linux
Posts: 7
Joined: Tue Jan 07, 2020 10:21 am
Has thanked: 0
Been thanked: 1 time

Re: Airmaster 4000D Not pulling in tower signal on verified band 41

Post by 417linux » Tue Jan 07, 2020 2:04 pm

Sounds good, I'll try that tonight. Thanks

417linux
Posts: 7
Joined: Tue Jan 07, 2020 10:21 am
Has thanked: 0
Been thanked: 1 time

Re: Airmaster 4000D Not pulling in tower signal on verified band 41

Post by 417linux » Wed Jan 08, 2020 9:07 am

The only update I was able to find besides a firmware update was an admin password update. I didn't see a "user profile" update. I still couldn't get it to connect to the tower properly after that. Any other suggestions? Do you think there may be something wrong with the unit?

stcabay1
Posts: 11
Joined: Sun Dec 30, 2018 11:24 pm
Has thanked: 0
Been thanked: 5 times

Re: Airmaster 4000D Not pulling in tower signal on verified band 41

Post by stcabay1 » Wed Jan 08, 2020 8:03 pm

I had similar issues with my Airmaster 4000D when using it at my house. Eventually I got it working everywhere except for near my house. Was really odd, but with some setting changes I was finally able to get it going at home and it has been rock solid since. If I didn't change all of these settings nothing would seems to work. The first signal light would just blink and no signal stats would appear in the admin interface. PLMN search would bring up nothing. Here's how I got mine going:

1. Place SIM in original hotspot
2. Go to the hotspot admin page
3. Go to the "About" tab and gather the APN from the wwan area
1.PNG
1.PNG (15.61 KiB) Viewed 8595 times
4. Go to the "Debug" page and gather the MCC, MNC, Physical Cell ID and DL Channel
2.PNG
5. Connect to the Airmaster (If you've messed with things do a factory reset)
6. Enter the APN from step 3 on the Bearer Settings tab
3.PNG
3.PNG (12.88 KiB) Viewed 8595 times
7. Enter the DL Channel and Physical Cell ID from step 4 on the eNB Settings tab. Check Preferred eNB List and Enable Lock ND&S to the preferred list
4.PNG
8. Enter the MCC and MNC from step 4 on the PLMN Selection tab. Switch to Nomadic and check Allow Roaming
5.PNG
9. Straddle the DL Channel from step 4 on the ND&S tab. Select band 41 then just enter a Start Earcfn and End Earcfn that contains the value. The page will only allow a range of 15 so in my example I did 40970 to 40985 to straddle 40978
6.PNG
10. Save everything
11. Unplug the modem
12. Insert sim
13. Plug in modem

If everything worked similarly to mine you'll have a connection in about 5 minutes. Mine has been up for weeks with no noticeable disconnects

417linux
Posts: 7
Joined: Tue Jan 07, 2020 10:21 am
Has thanked: 0
Been thanked: 1 time

Re: Airmaster 4000D Not pulling in tower signal on verified band 41

Post by 417linux » Thu Jan 09, 2020 1:38 pm

I bet this will do it! I'm going to try this when I get back tonight. That looks to be the same franklin debug info page I get on my old router. Thanks for taking the time to put this together! I'll keep you posted on the results.

stcabay1
Posts: 11
Joined: Sun Dec 30, 2018 11:24 pm
Has thanked: 0
Been thanked: 5 times

Re: Airmaster 4000D Not pulling in tower signal on verified band 41

Post by stcabay1 » Thu Jan 09, 2020 4:06 pm

Hope it work out for you. Be sure to give it at least 5 minutes to connect once you go through all the steps. A lot of people report nearly instant connections with these, but even with these settings mine takes a while. Mine even goes through a few iterations of connecting then disconnected on th admin page before it establishes. Once connected it's solid and reconnects are nearly instant

Post Reply