NEXP1GO and EM7565 Connection Issues

Related to Router Devices ONLY
Forum rules
Use the SEARCH function for related issues PRIOR to posting for assistance.
User avatar
Didneywhorl
Posts: 2776
Joined: Fri Mar 23, 2018 5:37 pm
Location: USA
Has thanked: 1064 times
Been thanked: 580 times
Contact:

Re: NEXP1GO and EM7565 Connection Issues

Post by Didneywhorl » Fri Nov 19, 2021 1:31 pm

Its hard to say. Make sure the APN is set right and your system time and time zone as well. In general with all settings set right for the SIM plan used it should connect right up.

colelail
Posts: 23
Joined: Tue Nov 16, 2021 7:43 pm
Has thanked: 0
Been thanked: 0

Re: NEXP1GO and EM7565 Connection Issues

Post by colelail » Fri Nov 19, 2021 2:14 pm

So, I’ve from the Chinese recovery screen I uploaded a .bin firmware and am now showing MediaTek OpenWrt.

Seeing how I was just wanting to go from telestra to generic, I feel like this is a completely different platform.

Do you mind pointing me to the firmware download that I can enter?

MattB29
Posts: 221
Joined: Wed Jul 08, 2020 3:09 pm
Has thanked: 17 times
Been thanked: 49 times

Re: NEXP1GO and EM7565 Connection Issues

Post by MattB29 » Fri Nov 19, 2021 3:49 pm

Sorry to interupt but the OP seems to be confusing his router firmware with the modems firmware. Different things.

colelail
Posts: 23
Joined: Tue Nov 16, 2021 7:43 pm
Has thanked: 0
Been thanked: 0

Re: NEXP1GO and EM7565 Connection Issues

Post by colelail » Fri Nov 19, 2021 4:48 pm

I now know what Mike829 is saying.

I am now back to the original router firmware and have the modem set to "Generic" but I still am not getting internet connection. I also synched the time again.

AT!IMPREF?
!IMPREF:
preferred fw version: 01.07.02.00
preferred carrier name: GENERIC
preferred config name: GENERIC_002.004_001
current fw version: 01.07.02.00
current carrier name: GENERIC
current config name: GENERIC_002.004_001

OK

Anything else I could attempt?

MattB29
Posts: 221
Joined: Wed Jul 08, 2020 3:09 pm
Has thanked: 17 times
Been thanked: 49 times

Re: NEXP1GO and EM7565 Connection Issues

Post by MattB29 » Sat Nov 20, 2021 8:03 am

Reading through your OP you state that your sim previously worked in Franklin t-9. What is the plan you are using? It is possible that T-Mobile has locked the sim to the Franklin's IMEI. If so you will need a different plan and sim.

colelail
Posts: 23
Joined: Tue Nov 16, 2021 7:43 pm
Has thanked: 0
Been thanked: 0

Re: NEXP1GO and EM7565 Connection Issues

Post by colelail » Sat Nov 20, 2021 8:42 am

I am using the Calyx Institute plan. I thought it was originally a Sprint program, but when looking in the browser of the T9 with the SIM I noticed it was on the fast.t-mobile.com. I asked LTE FIX before purchasing and they thought that it should work. Is it possible to "flash" the IMEI onto this router?

This rural life is awesome except for getting reasonable internet....

MattB29
Posts: 221
Joined: Wed Jul 08, 2020 3:09 pm
Has thanked: 17 times
Been thanked: 49 times

Re: NEXP1GO and EM7565 Connection Issues

Post by MattB29 » Sat Nov 20, 2021 10:40 am

They will not discuss IMEI alteration of the modem on the Forum here.

Sounds like either the vendor or your Internet supplier would have to address the issue of your setup working. I am neither. Just help when I think I can.

User avatar
Didneywhorl
Posts: 2776
Joined: Fri Mar 23, 2018 5:37 pm
Location: USA
Has thanked: 1064 times
Been thanked: 580 times
Contact:

Re: NEXP1GO and EM7565 Connection Issues

Post by Didneywhorl » Sat Nov 20, 2021 3:51 pm

Are you using fast.t-mobile.com for the APN on your settings?

Run

Code: Select all

AT+CGDCONT?
and show us the output

colelail
Posts: 23
Joined: Tue Nov 16, 2021 7:43 pm
Has thanked: 0
Been thanked: 0

Re: NEXP1GO and EM7565 Connection Issues

Post by colelail » Sat Nov 20, 2021 5:18 pm

Yes.

AT+CGDCONT?
+CGDCONT: 1,"IPV4V6","fast.t-mobile.com","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

OK

I've also tried the r.ispn. I feel like I'm missing something fairly elementary, but can't figure it out...

User avatar
Didneywhorl
Posts: 2776
Joined: Fri Mar 23, 2018 5:37 pm
Location: USA
Has thanked: 1064 times
Been thanked: 580 times
Contact:

Re: NEXP1GO and EM7565 Connection Issues

Post by Didneywhorl » Sun Nov 21, 2021 1:18 pm

add via AT command:

Code: Select all

AT+CGDCONT=2,"IP","otasn"
and

Code: Select all

AT+CGDCONT=3,"IPV4V6","fast.t-mobile.com"

You'll almost always want to use the APN that the hotspot is set to.

Post Reply