TTL issues with Cricket or something else?

Related to Router Devices ONLY
Forum rules
Use the SEARCH function for related issues PRIOR to posting for assistance.
Post Reply
backdrop-scrounger
Posts: 4
Joined: Tue Sep 08, 2020 4:58 pm
Has thanked: 0
Been thanked: 0

TTL issues with Cricket or something else?

Post by backdrop-scrounger » Tue Apr 27, 2021 1:51 pm

I've been using a GL.iNet AR750s as a travel router for about 8 months now, doing USB tether from a phone plugged into it.

I tried Visible (terrible speeds where I was. Like dial-up bad). I moved to a 100GB Cricket data-only plan, which was great, but I would run out of data every month so it was kinda crappy. I did a 100GB T-Mobile data-only plan, and it was pretty meh. Speeds weren't great, but what I've finally settled on was an Unlimited Cricket plan (the $60/month) one and changing the TTL.

I just setup a custom firewall rule to do this:

Code: Select all

iptables -t mangle -I POSTROUTING -o usb0 -j TTL --ttl-set 65
This has gotten me the best speeds and no data caps (I use about 125GB-180GB month), but I have some really random issues with it. It seems like the more devices are using the WiFi from the router, the more issues I have. The biggest issue is that randomly sites will just fail to load because the DNS couldn't resolve. It's totally random and refreshing about 10-20 times will eventually make it work. It never happened on any of my other plans, so I'm wondering if it's an issue of the TTL being modified or something? Do I need to play with MTU as well?

Dr-BroadBand
Posts: 357
Joined: Wed Sep 23, 2020 8:52 am
Location: Texas
Has thanked: 76 times
Been thanked: 64 times

Re: TTL issues with Cricket or something else?

Post by Dr-BroadBand » Fri May 14, 2021 9:40 pm

What DNS are you using ??

Post Reply