Orbi LBR20 How-To / Megathread

How To Tutorials related to Routers and Firmware
Forum rules
This forum is for tutorials only--not for help or assistance.
mtnchar
Posts: 8
Joined: Sat Feb 20, 2021 1:12 pm
Has thanked: 0
Been thanked: 0

Re: Orbi LBR20 How-To / Megathread

Post by mtnchar » Sat Apr 03, 2021 1:31 pm

outrage18 wrote:
Fri Mar 26, 2021 2:39 pm
Never used the orbi app, but Netgear tells me that it will notify me of updated fw availability. SOO, I just installed the Android version and lo and behold, it is gave me an option to update to fw version 2.6.4.2; which is NOT available on the Netgear LBR20 download site... Since, I've little to lose, I upgraded. As expected, lbr worked fine after upgrade and survived 2 reboots.

I then tried the circle_jerk automated install script which failed with message "...No connection could be made because the target machine actively refused it at 192.168.1.1:23" However, manual install worked. I was able to enable circle, ssh in and make minimal necessary changes to call_once and fw_rules scripts. Speedtest.net showed excellent unthrottled speeds on Visible. I then rebooted and once again the LBR failed to connect. Statistics is showing "link Down" for WAN, LAN and LTE. Connection status shows 0.0.0.0 both for IP address and DNS Server; while SIM is READY and SIM IMSI is shown correctly. In addition, Band Number is shown as '2' which is a Visible/vzw band available here. But Connection Status is 'disconnected'

Update: Netgear is processing an RMA to replace my unit.
I have had the exact same issue on Visible with 2.5.2.20 and FW A05. I am not sure what causes this to happen. I switched my LBR20s so the one refusing to connect to Visible connected to ATT without issues. The other LBR20 had been on ATT for months connected with the Visible sim with no issue. I just had to update the configurations a bit (just the APNs).
I haven't yet tried to switch back. I am wondering if something in the Visible SIM config is causing the issue.

What is the best way to factory reset the modem of the LBR20? Is the AT&F command the best way to restore the modem to factory defaults and delete carrier network configurations? I have not tried sending the modem this command to see if this might fix the issue, then re-insert the SIM as things are working now, but I suspect the same issue will eventually happen to all my LBR20s with Visible.

gscheb
Posts: 1175
Joined: Tue Sep 10, 2019 10:37 am
Has thanked: 62 times
Been thanked: 228 times

Re: Orbi LBR20 How-To / Megathread

Post by gscheb » Sat Apr 03, 2021 3:15 pm

Hello,
Skimmed thru this whole post. Wanting to know if you can use a AT&T post pay tablet plan with little effort? Been using it in a Netgear LB1120 with AT&T post pay tablet plan with no issues. Just this is an out of date device Category 4 modem with no band 66. Just looking to upgrade but want to keep it simple. Like change the APN and ready to go simple.

outrage18
Posts: 10
Joined: Thu May 28, 2020 3:41 pm
Has thanked: 0
Been thanked: 1 time

Re: Orbi LBR20 How-To / Megathread

Post by outrage18 » Mon Apr 05, 2021 12:22 pm

ATT Post pay tablet plan will work with just APN change - but you risk termination as TOS requires SIM be used only in a tablet.

egauk
Posts: 11
Joined: Mon Mar 08, 2021 11:51 am
Has thanked: 3 times
Been thanked: 2 times

Re: Orbi LBR20 How-To / Megathread

Post by egauk » Wed Apr 07, 2021 12:37 pm

How is everyone using custom DNS when Circle is enabled?

With Circle enabled the custom/static DNS option cannot be selected in the UI? With Circle disabled I can set custom DNS, but then it reverts back to dynamic when I re-enable Circle.

egauk
Posts: 11
Joined: Mon Mar 08, 2021 11:51 am
Has thanked: 3 times
Been thanked: 2 times

Re: Orbi LBR20 How-To / Megathread

Post by egauk » Thu Apr 08, 2021 8:01 am

hazarjast wrote:
Fri Mar 12, 2021 8:42 am
That works :)

Sounds good, I will be upgrading my stable unit to the newer firmware this weekend to use 'circle_jerk' as Voxel appears to have now accepted my offer to ship my 'dev' unit to him so that he can release his firmware for the LBR20. Hopefully one day soon this will mean we no longer have to bootstrap off of anything but can run the device in any way we wish without dancing around Netgear's code.

No problem!
Fingers crossed that Voxel is able to release his firmware for the LBR20 8-)

outrage18
Posts: 10
Joined: Thu May 28, 2020 3:41 pm
Has thanked: 0
Been thanked: 1 time

Re: Orbi LBR20 How-To / Megathread

Post by outrage18 » Fri Apr 09, 2021 12:37 am

egauk wrote:
Wed Apr 07, 2021 12:37 pm
How is everyone using custom DNS when Circle is enabled?

With Circle enabled the custom/static DNS option cannot be selected in the UI? With Circle disabled I can set custom DNS, but then it reverts back to dynamic when I re-enable Circle.
This custom DNS server example uses Google public DNS servers
In the /mnt/circle/mods directory, create a new resolv.conf file, that contains the IP addresses of your desired DNS servers
vi resolv.conf
Hit ‘a’ to append and paste in the following lines:

nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 2001:4860:4860::8888 # IPV6 wwan0
nameserver 2001:4860:4860::8844 # IPV6 wwan0

Write & Quit
Esc
:wq
Edit the ‘call_recurring’ script
vi call_recurring
Using arrow buttons, navigate to the end of the last line of the script, hit a to append from that location, hit enter twice to leave a blank line and start a new line then paste in the following

# This command periodically overwrites stock DNS servers with the ones you
# saved in the new resolv.conf file
cp /mnt/circle/mods/resolv.conf /tmp/resolv.conf

Write & Quit
esc
:wq

Reboot; give it a couple minutes after the LBR20’s WiFi link comes up and load up 192.168.1.1/adv_index.htm, you should see the Google IPv4 DNS servers, or the ones you choose to use under INTERNET PORT

frank33v
Posts: 5
Joined: Thu Nov 19, 2020 6:54 pm
Has thanked: 0
Been thanked: 0

Re: Orbi LBR20 How-To / Megathread

Post by frank33v » Sat Apr 10, 2021 5:34 am

frank33v wrote:
Fri Apr 02, 2021 10:12 am
I have been using my Orbi LBR20 on AT&T successfully now all winter following the original instructions with the ttl mod script and shutting down wifi and blocking updates.

I am on 2.5.2.20 and FW A05.

For some reason my MAGIC keeps reverting back and it I lose internet connection. Reboot, redo magic and I am back in business. Less than 24hrs later it happens again.

IS this a known issues now? Do I need to upgrade and try to figure out this new process listed above to make my Orbi stable with AT&T.

Bump...Is this a known issue?? Do I need to upgrade and figure out the circle_jerk hack? Perhaps my firmware got corrupted? I did have a power outage.

shinesmart
Posts: 14
Joined: Tue Feb 23, 2021 7:32 pm
Has thanked: 0
Been thanked: 2 times

Re: Orbi LBR20 How-To / Megathread

Post by shinesmart » Fri Apr 16, 2021 12:37 am

Finally was able to find the LTE downgrade file to go from A06 back to A05.

https://www.downloads.netgear.com/files ... ge(US).zip

Hope this helps if anyone needs to downgrade.

mtnchar
Posts: 8
Joined: Sat Feb 20, 2021 1:12 pm
Has thanked: 0
Been thanked: 0

Re: Orbi LBR20 How-To / Megathread

Post by mtnchar » Tue May 04, 2021 9:28 pm

frank33v wrote:
Sat Apr 10, 2021 5:34 am
Bump...Is this a known issue?? Do I need to upgrade and figure out the circle_jerk hack? Perhaps my firmware got corrupted? I did have a power outage.
What magic is getting lost? Did this unit every get upgraded beyond 2.5.2.20, this seems to affect persistence of settings and I would go forward and try hazarjast's solution for the newest updates. If not I would upgrade the LTE firmware to A06 as this did help some settings for me that seems to be spontaneously resetting.

wasabi
Posts: 1
Joined: Tue May 18, 2021 2:25 pm
Has thanked: 0
Been thanked: 1 time

Re: Orbi LBR20 How-To / Megathread

Post by wasabi » Tue May 18, 2021 2:56 pm

I completed the upgrade today and wanted to share - as I went ahead and jumped to the most recent firmware V2.6.4.2. Happy to report that circle_jerk installs just fine with this version and as far as I can tell works.

My speed test just after the install is great (possibly better than before) but I haven't had any real run time with it yet (literally just finished the process).

For reference and to possibly help newbies - here are the steps I did:

1. Used WebUI to Reset to Factory (Administration > Backup Settings)
a. Note: this resets the Orbi to 192.168.1.1
2. Set admin password and recovery questions, left everything else default skipping where possible
3. Updated to V2.5.3.4 firmware via pre-downloaded zip (Orbi was not connected to internet)
a. Probably not needed but I did it by accident (chose wrong file lol)
4. Updated to V2.6.3.50 firmware via pre-downloaded zip (Orbi was not connected to internet)
a. This was in the OP
5. Connected to Orbi to internet/LTE by updating the APN
a. I'm using Calyx so only needed to set this to r.ispsn
6. Updated to V2.6.4.2 firmware via WebUI directly
a. Had not seen any comments about this version so it must be super new
7. Updated LTE Firmware from R01A05 to R01A06 via WebUI directly
8. After all firmware updates completed successfully - performed another factory reset
a. Probably not needed but I wanted a completely clean slate and since I hadn't done any actual configuration yet, so why not
9. Set admin password and recovery questions
10. Selected the mobile network configuration for Sprint\T-Mobile via the new /hidden_info.htm page
a. Selected: Commerical-TMO
b. Note: This does not set the APN - that will be done later
11. Set my desired internal IP and DHCP Range (eg: Change the LAN Setup IP to: 10.10.10.1)
12. Installed Circle_Jerk following Manual Instructions
a. Far simpler than I thought it would be to be honest
13. Rebooted
14. Logged into SSH via Putty (success)
15. Configuration of Circle_Jerk was completed:
a. Disabled WiFi
b. Configured the modem
c. Disabled Netgear IOT check-ins
d. Set DNS nameservers to Google DNS (instructions from a post in this megathread)
16. Adjusted the Authentication Type to IPv4v6
17. Rebooted
-Complete-

Thank you Hazarjast and to the many others that have posted tips and tricks in this megathread!

Post Reply