Orbi LBR20 How-To / Megathread

How To Tutorials related to Routers and Firmware
Forum rules
This forum is for tutorials only--not for help or assistance.
Username
Posts: 3
Joined: Sun Jan 17, 2021 8:01 am
Has thanked: 1 time
Been thanked: 1 time

Re: Orbi LBR20 How-To / Megathread

Post by Username » Thu Feb 04, 2021 6:04 pm

Username wrote:
Sun Jan 24, 2021 8:59 am
Thank you for your reply. My personal mobile phone sim is also a SimpleMobile, and it works when I go to my parents home....which is the source of my confusion ;-). I haven't tried my personal sim into the LBR20 yet, that might be an interesting test but that prolly won't help me understand the issue with the current sim. Per your advice, I may end up trying a first-party sim instead of simplemobile.
I tried one more MVNO sim - this time from US Mobile (which had even more data per month than SimpleMobile).

This time the sim worked both at my house, and at my parents house which is 20 miles away. It worked like a charm. Now my parents have internet and are also an echo dot instead of a computer.

I'm not really sure why US Mobile worked but the SimpleMobile did not (recall that the SimpleMobile worked at my house but not theirs). That pretty much ends my issue for now. Thanks for this site, and this thread. Good stuff here.

das1996
Posts: 2
Joined: Fri Feb 12, 2021 11:57 pm
Has thanked: 0
Been thanked: 0

Re: Orbi LBR20 How-To / Megathread

Post by das1996 » Sat Feb 13, 2021 12:01 am

I must be missing something. I can't get anything under /mnt/ntgr/armor, or /mnt/ntgr/armor/etc, or cd /mnt/ntgr/armor/etc/init.d/ to persist between reboots. Tried the 2.5.2.20 and 2.5.3.4 uscc fw on the unit. Completed initial config, even put a sim in it. After every reboot, anything I add is gone.

Any suggestions? Thanks!

outrage18
Posts: 3
Joined: Thu May 28, 2020 3:41 pm
Has thanked: 0
Been thanked: 0

Re: Orbi LBR20 How-To / Megathread

Post by outrage18 » Thu Feb 18, 2021 12:03 am

das1996,
Persists fine on 2.5.2.20 so long as you don't upgrade to 2.5.3.4. BTW, I learned the hard way -- new fw loses telnet option from the debug page and when I downgraded back to 2,.5.2.20, the changes (which used to persist) no longer survive reboot.

das1996
Posts: 2
Joined: Fri Feb 12, 2021 11:57 pm
Has thanked: 0
Been thanked: 0

Re: Orbi LBR20 How-To / Megathread

Post by das1996 » Thu Feb 18, 2021 12:06 am

Mine was on 2.5.3.4 at some point... Auto updated I believe. Any way to undo whatever 2.5.3.4 so 2.5.2.20 works like before?

outrage18
Posts: 3
Joined: Thu May 28, 2020 3:41 pm
Has thanked: 0
Been thanked: 0

Re: Orbi LBR20 How-To / Megathread

Post by outrage18 » Thu Feb 18, 2021 10:47 am

Not within my capabilities, if at all. Not sure you were auto upgraded to 2.6.3.50; for the time being, Netgear does not seem to be auto updating beyond 2.5.2.20. My effort to try and get changes on the armor directory to survive a reboot included reverting to both 2.5.2.20 and 2.5.1.18 as well as hard reset. Nothing I did worked :(

hazarjast
Posts: 24
Joined: Wed Dec 11, 2019 8:38 am
Has thanked: 2 times
Been thanked: 11 times

Re: Orbi LBR20 How-To / Megathread

Post by hazarjast » Fri Feb 19, 2021 1:42 pm

outrage18 wrote:
Thu Feb 18, 2021 10:47 am
Not within my capabilities, if at all. Not sure you were auto upgraded to 2.6.3.50; for the time being, Netgear does not seem to be auto updating beyond 2.5.2.20. My effort to try and get changes on the armor directory to survive a reboot included reverting to both 2.5.2.20 and 2.5.1.18 as well as hard reset. Nothing I did worked :(
There are clues to resolve here:
https://hackingthenetgearorbi.wordpress ... this-time/

As the blog above shows, not all free space on Orbi devices have been partitioned for use with overly-fs so in the newer firmware for LBR20 it should still be possible to partition some space that survives a reboot. Plus, you have to think, Armor (BitDefender) receives updates which need to be loaded at reboot so they are being stored somewhere in a persistent manner.

I got a fleaBay deal on a used LBR20 which will allow me to have a 'dev' unit to play around with while my daily driver stays safely on older firmware but my day job is very demanding at the moment so it may be some time before I get a chance to work a fully functioning solution for folks on newer firmware. For telnet access, there's no way that Netgear would permanently lock their support staff out of that, it's just harder to get to now most likely. Something like this should make it accessible:

https://github.com/insanid/NetgearTelnetEnable

As an aside, I also have SSH fully working on the LBR20 2.5.2.20 firmware which is much nicer than telnet (no timeouts, weird formatting on the command line, putty window resizing issues, etc. that are seen when using telnet). Once I get the persistent storage issue sorted on the newer firmware I'll add instructions on adding SSH as well :)

mtnchar
Posts: 1
Joined: Sat Feb 20, 2021 1:12 pm
Has thanked: 0
Been thanked: 0

Re: Orbi LBR20 How-To / Megathread

Post by mtnchar » Tue Feb 23, 2021 9:19 am

Thank you for all your help hazarjast. The orbi has greatly improved speed vs the old mofi and helped make the internet far more usable at my location. I took your advice and blocked all the auto-update features, although it seems to know about the LTE firmware despite my efforts.

Now my Orbi wants to do a LTE modem firmware upgrade, of course couldn't find anything about this upgrade on the netgear website. They never actually note what this upgrades supposedly fix.

I have noted they appear to be blowing out the LBR20s, there is probably a newer (and less adaptable) model coming out.

Anyone try this new LTE firmware PAR01A06M4G

US Cellular has a link about it, but few real details.

https://www.uscellular.com/content/dam/ ... Router.pdf

shinesmart
Posts: 1
Joined: Tue Feb 23, 2021 7:32 pm
Has thanked: 0
Been thanked: 1 time

Re: Orbi LBR20 How-To / Megathread

Post by shinesmart » Tue Feb 23, 2021 7:44 pm

Got everything working on the 2.5.3.4 version. After doing the TTL mod via telnet, I’m consistently getting 60/30 with Visible sim and the scripts are surviving reboots. Much thanks hazerjast for this tutorial. LBR20 seems like the best tri-band lte router once you get the TTL mod working. Let me know if I can help with in any way.

Cheers 🍺

Post Reply