No Modem Present

Misc Mini PCI-E and M.2 Modem Card Topics
Post Reply
gabe1475
Posts: 32
Joined: Wed Aug 18, 2021 9:12 am
Has thanked: 1 time
Been thanked: 4 times

No Modem Present

Post by gabe1475 » Fri Oct 08, 2021 9:21 am

Has anyone received this in the Network status page?

LoveMeSomeCALTE
Posts: 236
Joined: Sun Jul 05, 2020 2:29 pm
Has thanked: 235 times
Been thanked: 27 times

Re: No Modem Present

Post by LoveMeSomeCALTE » Fri Oct 08, 2021 10:24 am

Yes.

You would then go look at the system and kernel logs to see what the issue is unless it's a faulty regulator or connection.

gabe1475
Posts: 32
Joined: Wed Aug 18, 2021 9:12 am
Has thanked: 1 time
Been thanked: 4 times

Re: No Modem Present

Post by gabe1475 » Fri Oct 08, 2021 10:44 am

think I found it.

gabe1475
Posts: 32
Joined: Wed Aug 18, 2021 9:12 am
Has thanked: 1 time
Been thanked: 4 times

Re: No Modem Present

Post by gabe1475 » Fri Oct 08, 2021 10:52 am

[ 0.000000] Linux version 4.9.211 (dairyman@Compaq6300) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7976-ca47026b7d) ) #0 Wed Jan 29 16:06:05 2020
[ 0.000000] MyLoader: sysp=fff7ffff, boardp=ffffffff, parts=ffffffff
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[ 0.000000] SoC: Qualcomm Atheros QCA9533 ver 2 rev 0
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 08000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x0000000000000000-0x0000000007ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x0000000000000000-0x0000000007ffffff]
[ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[ 0.000000] On node 0 totalpages: 32768
[ 0.000000] free_area_init_node: node 0, pgdat 8047a8f4, node_mem_map 81000020
[ 0.000000] Normal zone: 256 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 32768 pages, LIFO batch:7
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 32512
[ 0.000000] Kernel command line: board=AP147-010 console=ttyS0,115200 mtdparts=spi0.0:256k(u-boot),64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware) rootfstype=squashfs noinitrd
[ 0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[ 0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Writing ErrCtl register=00024630
[ 0.000000] Readback ErrCtl register=00024630
[ 0.000000] Memory: 124816K/131072K available (3231K kernel code, 168K rwdata, 804K rodata, 268K init, 205K bss, 6256K reserved, 0K cma-reserved)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.000000] Clocks: CPU:550.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[ 0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6950037990 ns
[ 0.000011] sched_clock: 32 bits at 275MHz, resolution 3ns, wraps every 7809031678ns
[ 0.008903] Calibrating delay loop... 366.18 BogoMIPS (lpj=1830912)
[ 0.071923] pid_max: default: 32768 minimum: 301
[ 0.077307] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.084826] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.096460] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ 0.107699] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.115367] NET: Registered protocol family 16
[ 0.122283] MIPS: machine is Atheros AP147-010 reference board
[ 0.133490] ar724x-pci ar724x-pci.0: PCIe link is down
[ 0.139329] registering PCI controller with io_map_base unset
[ 0.643218] PCI host bridge to bus 0000:00
[ 0.647968] pci_bus 0000:00: root bus resource [mem 0x10000000-0x11ffffff]
[ 0.655764] pci_bus 0000:00: root bus resource [io 0x0000]
[ 0.662095] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[ 0.669797] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[ 0.678819] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[ 0.679684] clocksource: Switched to clocksource MIPS
[ 0.686750] NET: Registered protocol family 2
[ 0.692822] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.700821] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.708052] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.715415] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.722112] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.729555] NET: Registered protocol family 1
[ 0.734588] PCI: CLS 0 bytes, default 32
[ 0.740436] Crashlog allocated RAM at address 0x3f00000
[ 0.747870] workingset: timestamp_bits=30 max_order=15 bucket_order=0
[ 0.763223] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.769902] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.792640] io scheduler noop registered
[ 0.797095] io scheduler deadline registered (default)
[ 0.803480] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[ 0.811253] console [ttyS0] disabled
[ 0.835488] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a 16550A
[ 0.845303] console [ttyS0] enabled
[ 0.852867] bootconsole [early0] disabled
[ 0.866069] m25p80 spi0.0: found w25q128, expected m25p80
[ 0.881465] m25p80 spi0.0: w25q128 (16384 Kbytes)
[ 0.886382] 6 cmdlinepart partitions found on MTD device spi0.0
[ 0.892524] Creating 6 MTD partitions on "spi0.0":
[ 0.897487] 0x000000000000-0x000000040000 : "u-boot"
[ 0.905162] 0x000000040000-0x000000050000 : "u-boot-env"
[ 0.913347] 0x000000050000-0x000000e80000 : "rootfs"
[ 0.920482] mtd: device 2 (rootfs) set to be root filesystem
[ 0.926396] 1 squashfs-split partitions found on MTD device rootfs
[ 0.932868] 0x0000007d0000-0x000000e80000 : "rootfs_data"
[ 0.941260] 0x000000e80000-0x000000ff0000 : "kernel"
[ 0.948947] 0x000000ff0000-0x000001000000 : "art"
[ 0.956454] 0x000000050000-0x000000ff0000 : "firmware"
[ 0.965698] libphy: Fixed MDIO Bus: probed
[ 0.996893] libphy: ag71xx_mdio: probed
[ 1.632255] ag71xx-mdio.1: Found an AR934X built-in switch
[ 1.685757] eth0: Atheros AG71xx at 0xba000000, irq 5, mode:GMII
[ 2.322659] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd042, driver=Generic PHY]
[ 2.333004] eth1: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[ 2.341452] NET: Registered protocol family 10
[ 2.351022] NET: Registered protocol family 17
[ 2.355806] 8021q: 802.1Q VLAN Support v1.8
[ 2.367365] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 2.376885] Freeing unused kernel memory: 268K
[ 2.381511] This architecture does not have kernel memory protection.
[ 2.559709] random: fast init done
[ 3.184032] init: Console is alive
[ 3.187826] init: - watchdog -
[ 5.271884] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[ 5.447187] usbcore: registered new interface driver usbfs
[ 5.453027] usbcore: registered new interface driver hub
[ 5.458626] usbcore: registered new device driver usb
[ 5.472629] exFAT: Version 1.2.9
[ 5.522521] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 5.541145] SCSI subsystem initialized
[ 5.551998] ehci-platform: EHCI generic platform driver
[ 5.557552] ehci-platform ehci-platform: EHCI Host Controller
[ 5.563573] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 5.573908] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 5.609733] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[ 5.617337] hub 1-0:1.0: USB hub found
[ 5.621741] hub 1-0:1.0: 1 port detected
[ 5.630042] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 5.638405] ohci-platform: OHCI generic platform driver
[ 5.647448] uhci_hcd: USB Universal Host Controller Interface driver
[ 5.660232] usbcore: registered new interface driver usb-storage
[ 5.667409] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[ 5.677294] init: - preinit -
[ 6.259769] usb 1-1: new high-speed USB device number 2 using ehci-platform
[ 6.640651] hub 1-1:1.0: USB hub found
[ 6.647773] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 6.654290] hub 1-1:1.0: 4 ports detected
[ 6.707152] random: procd: uninitialized urandom read (4 bytes read)
[ 9.986374] mount_root: loading kmods from internal overlay
[ 10.067902] kmodloader: loading kernel modules from //etc/modules-boot.d/*
[ 10.077451] kmodloader: done loading kernel modules from //etc/modules-boot.d/*
[ 10.819044] jffs2: notice: (412) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[ 10.837777] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[ 10.866490] block: extroot: not configured
[ 10.962983] jffs2: notice: (410) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[ 11.234155] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[ 11.262512] block: extroot: not configured
[ 11.268097] mount_root: switching to jffs2 overlay
[ 11.347856] urandom-seed: Seeding with /etc/urandom.seed
[ 11.524173] procd: - early -
[ 11.527330] procd: - watchdog -
[ 12.206751] procd: - watchdog -
[ 12.220132] procd: - ubus -
[ 12.616581] random: ubusd: uninitialized urandom read (4 bytes read)
[ 12.634417] random: ubusd: uninitialized urandom read (4 bytes read)
[ 12.660237] random: ubusd: uninitialized urandom read (4 bytes read)
[ 12.667944] procd: - init -
[ 13.634465] kmodloader: loading kernel modules from /etc/modules.d/*
[ 13.702628] tun: Universal TUN/TAP device driver, 1.6
[ 13.707857] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[ 13.751849] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 13.791481] Netfilter messages via NETLINK v0.30.
[ 13.805407] ip_set: protocol 6
[ 13.932858] u32 classifier
[ 13.935672] input device check on
[ 13.939451] Actions configured
[ 13.962972] Mirror/redirect action on
[ 13.992871] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
[ 14.028448] fuse init (API version 7.26)
[ 14.066454] usbcore: registered new interface driver cdc_acm
[ 14.072393] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[ 14.093813] usbcore: registered new interface driver cdc_wdm
[ 14.116365] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
[ 14.124724] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
[ 14.155606] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 14.171310] usbcore: registered new interface driver ipheth
[ 14.198911] ctnetlink v0.93: registering with nfnetlink.
[ 14.403083] usbcore: registered new interface driver usblp
[ 14.436509] usbcore: registered new interface driver usbserial
[ 14.442761] usbcore: registered new interface driver usbserial_generic
[ 14.449616] usbserial: USB Serial support registered for generic
[ 14.565440] xt_time: kernel timezone is -0000
[ 14.581150] usbcore: registered new interface driver cdc_ether
[ 14.605742] usbcore: registered new interface driver cdc_ncm
[ 14.684898] usbcore: registered new interface driver huawei_cdc_ncm
[ 14.824883] PPP generic driver version 2.4.2
[ 14.839907] NET: Registered protocol family 24
[ 14.856259] usbcore: registered new interface driver qmi_wwan
[ 14.877892] usbcore: registered new interface driver rndis_host
[ 14.931145] usbcore: registered new interface driver sierra
[ 14.937011] usbserial: USB Serial support registered for Sierra USB modem
[ 14.966469] usbcore: registered new interface driver sierra_net
[ 15.082930] usbcore: registered new interface driver cdc_mbim
[ 15.102862] usbcore: registered new interface driver option
[ 15.108724] usbserial: USB Serial support registered for GSM modem (1-port)
[ 15.137491] usbcore: registered new interface driver qcserial
[ 15.143639] usbserial: USB Serial support registered for Qualcomm USB modem
[ 15.203180] usbcore: registered new interface driver rt2800usb
[ 15.248498] ath: EEPROM regdomain: 0x0
[ 15.248511] ath: EEPROM indicates default country code should be used
[ 15.248514] ath: doing EEPROM country->regdmn map search
[ 15.248535] ath: country maps to regdmn code: 0x3a
[ 15.248541] ath: Country alpha2 being used: US
[ 15.248545] ath: Regpair used: 0x3a
[ 15.260845] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 15.266335] ieee80211 phy0: Atheros AR9531 Rev:2 mem=0xb8100000, irq=47
[ 15.321620] kmodloader: done loading kernel modules from /etc/modules.d/*
[ 17.626527] urandom_read: 5 callbacks suppressed
[ 17.626537] random: jshn: uninitialized urandom read (4 bytes read)
[ 33.541297] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 33.576444] br-lan: port 1(eth0.1) entered blocking state
[ 33.582120] br-lan: port 1(eth0.1) entered disabled state
[ 33.588209] device eth0.1 entered promiscuous mode
[ 33.593233] device eth0 entered promiscuous mode
[ 33.634059] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 33.712149] br-wan: port 1(eth1) entered blocking state
[ 33.717567] br-wan: port 1(eth1) entered disabled state
[ 33.723491] device eth1 entered promiscuous mode
[ 33.790648] IPv6: ADDRCONF(NETDEV_UP): br-wan: link is not ready
[ 34.463677] br-wan: port 2(eth1.2) entered blocking state
[ 34.469320] br-wan: port 2(eth1.2) entered disabled state
[ 34.475448] device eth1.2 entered promiscuous mode
[ 39.732303] eth0: link up (1000Mbps/Full duplex)
[ 39.737128] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 39.779884] br-lan: port 1(eth0.1) entered blocking state
[ 39.785488] br-lan: port 1(eth0.1) entered forwarding state
[ 39.819883] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 46.149813] usb 1-1.3: new high-speed USB device number 3 using ehci-platform
[ 46.358754] qmi_wwan: probe of 1-1.3:1.0 failed with error -22
[ 46.365215] option 1-1.3:1.0: GSM modem (1-port) converter detected
[ 46.372161] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB0
[ 46.380211] option 1-1.3:1.1: GSM modem (1-port) converter detected
[ 46.387045] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB1
[ 46.395322] option 1-1.3:1.2: GSM modem (1-port) converter detected
[ 46.402234] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB2
[ 46.410505] option 1-1.3:1.3: GSM modem (1-port) converter detected
[ 46.417330] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB3
[ 46.697359] cdc_mbim 1-1.3:1.4: cdc-wdm0: USB WDM device
[ 46.704350] cdc_mbim 1-1.3:1.4 wwan0: register 'cdc_mbim' at usb-ehci-platform-1.3, CDC MBIM, ea:c1:51:53:31:ee
[ 83.940342] random: crng init done
[ 85.458818] usb 1-1.3: USB disconnect, device number 3
[ 85.464685] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[ 85.473159] option 1-1.3:1.0: device disconnected
[ 85.478575] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[ 85.487045] option 1-1.3:1.1: device disconnected
[ 85.524727] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[ 85.533163] option 1-1.3:1.2: device disconnected
[ 85.538458] option1 ttyUSB3: GSM modem (1-port) converter now disconnected from ttyUSB3
[ 85.546915] option 1-1.3:1.3: device disconnected
[ 85.552090] cdc_mbim 1-1.3:1.4 wwan0: unregister 'cdc_mbim' usb-ehci-platform-1.3, CDC MBIM
[ 85.763062] do_page_fault(): sending SIGSEGV to gcom for invalid write access to 0041c000
[ 85.771584] epc = 004036e9 in comgt[400000+6000]
[ 85.776387] ra = 0040369d in comgt[400000+6000]
[ 85.897658] hub 1-1:1.0: hub_ext_port_status failed (err = -71)
[ 85.913738] usb 1-1-port3: cannot reset (err = -71)
[ 85.939751] usb 1-1-port3: cannot reset (err = -71)
[ 85.950030] usb 1-1-port3: cannot reset (err = -71)
[ 85.969802] usb 1-1-port3: cannot reset (err = -71)
[ 85.974858] usb 1-1-port3: Cannot enable. Maybe the USB cable is bad?
[ 86.004749] usb 1-1-port3: cannot disable (err = -71)
[ 86.031602] usb 1-1-port3: cannot reset (err = -71)
[ 86.048493] usb 1-1-port3: cannot reset (err = -71)
[ 86.076396] usb 1-1-port3: cannot reset (err = -71)
[ 86.089990] usb 1-1-port3: cannot reset (err = -71)
[ 86.109215] usb 1-1-port3: cannot reset (err = -71)
[ 86.114467] usb 1-1-port3: Cannot enable. Maybe the USB cable is bad?
[ 86.155856] usb 1-1-port3: cannot disable (err = -71)
[ 86.161185] usb 1-1-port3: attempt power cycle
[ 86.524193] usb 1-1-port3: cannot reset (err = -71)
[ 86.533349] usb 1-1-port3: cannot reset (err = -71)
[ 86.559408] usb 1-1-port3: cannot reset (err = -71)
[ 86.572602] usb 1-1-port3: cannot reset (err = -71)
[ 86.598761] usb 1-1-port3: cannot reset (err = -71)
[ 86.603913] usb 1-1-port3: Cannot enable. Maybe the USB cable is bad?
[ 86.644661] usb 1-1-port3: cannot disable (err = -71)
[ 86.654352] usb 1-1-port3: cannot reset (err = -71)
[ 86.686033] usb 1-1-port3: cannot reset (err = -71)
[ 86.706019] usb 1-1-port3: cannot reset (err = -71)
[ 86.726369] usb 1-1-port3: cannot reset (err = -71)
[ 86.744990] usb 1-1-port3: cannot reset (err = -71)
[ 86.750134] usb 1-1-port3: Cannot enable. Maybe the USB cable is bad?
[ 86.779434] usb 1-1-port3: cannot disable (err = -71)
[ 86.784766] usb 1-1-port3: unable to enumerate USB device
[ 86.825377] usb 1-1-port3: cannot disable (err = -71)
[ 88.309815] usb 1-1.3: new high-speed USB device number 8 using ehci-platform
[ 88.501038] qmi_wwan: probe of 1-1.3:1.0 failed with error -22
[ 88.507437] option 1-1.3:1.0: GSM modem (1-port) converter detected
[ 88.514406] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB0
[ 88.522469] option 1-1.3:1.1: GSM modem (1-port) converter detected
[ 88.530277] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB1
[ 88.538465] option 1-1.3:1.2: GSM modem (1-port) converter detected
[ 88.545400] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB2
[ 88.553660] option 1-1.3:1.3: GSM modem (1-port) converter detected
[ 88.560547] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB3
[ 88.750971] cdc_mbim 1-1.3:1.4: cdc-wdm0: USB WDM device
[ 88.758191] cdc_mbim 1-1.3:1.4 wwan0: register 'cdc_mbim' at usb-ehci-platform-1.3, CDC MBIM, ea:c1:51:53:31:ee
[ 258.993838] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 259.000066] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 262.065862] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 262.072091] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 265.137839] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 265.144063] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 268.209838] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 268.216061] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 271.281938] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 271.288168] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 274.353837] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 274.360068] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 279.057837] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 279.064059] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 282.129839] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 282.136067] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 285.201838] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 285.208065] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 288.273839] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 288.280065] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 291.020220] cdc_mbim 1-1.3:1.4: Error in flush path: -71
[ 309.233843] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 309.240068] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 312.305868] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 312.312094] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 315.377837] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 315.384066] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 318.449839] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 318.456065] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 321.521825] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 321.528054] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 324.593875] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 324.600098] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 329.873839] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 329.880064] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 332.945839] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 332.952064] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 336.017838] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 336.024062] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 339.089840] cdc_mbim 1-1.3:1.4: nonzero urb status received: -71
[ 339.096070] cdc_mbim 1-1.3:1.4: wdm_int_callback - 0 bytes
[ 341.820214] cdc_mbim 1-1.3:1.4: Error in flush path: -71
[ 345.806966] usb 1-1.3: USB disconnect, device number 8
[ 345.812814] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[ 345.821247] option 1-1.3:1.0: device disconnected
[ 345.826569] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[ 345.834997] option 1-1.3:1.1: device disconnected
[ 345.840359] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[ 345.848706] option 1-1.3:1.2: device disconnected
[ 345.854092] option1 ttyUSB3: GSM modem (1-port) converter now disconnected from ttyUSB3
[ 345.862537] option 1-1.3:1.3: device disconnected
[ 345.867642] cdc_mbim 1-1.3:1.4 wwan0: unregister 'cdc_mbim' usb-ehci-platform-1.3, CDC MBIM
[ 346.849980] usb 1-1: USB disconnect, device number 2
[ 356.481286] eth0: link down
[ 356.490060] br-lan: port 1(eth0.1) entered disabled state
[ 358.012185] eth0: link up (1000Mbps/Full duplex)
[ 358.018364] br-lan: port 1(eth0.1) entered blocking state
[ 358.024047] br-lan: port 1(eth0.1) entered forwarding state
[ 790.199723] usb 1-1: new high-speed USB device number 9 using ehci-platform
[ 790.395386] hub 1-1:1.0: USB hub found
[ 790.409991] hub 1-1:1.0: 4 ports detected
[ 790.759743] usb 1-1.3: new high-speed USB device number 10 using ehci-platform
[ 790.898920] qmi_wwan: probe of 1-1.3:1.0 failed with error -22
[ 790.905366] option 1-1.3:1.0: GSM modem (1-port) converter detected
[ 790.912323] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB0
[ 790.920365] option 1-1.3:1.1: GSM modem (1-port) converter detected
[ 790.927164] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB1
[ 790.935406] option 1-1.3:1.2: GSM modem (1-port) converter detected
[ 790.942315] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB2
[ 790.950556] option 1-1.3:1.3: GSM modem (1-port) converter detected
[ 790.957379] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB3
[ 791.060775] cdc_mbim 1-1.3:1.4: cdc-wdm0: USB WDM device
[ 791.067673] cdc_mbim 1-1.3:1.4 wwan0: register 'cdc_mbim' at usb-ehci-platform-1.3, CDC MBIM, ea:c1:51:53:31:ee

LoveMeSomeCALTE
Posts: 236
Joined: Sun Jul 05, 2020 2:29 pm
Has thanked: 235 times
Been thanked: 27 times

Re: No Modem Present

Post by LoveMeSomeCALTE » Fri Oct 08, 2021 11:42 am

The modem connects within 2 minutes of your bootup:

[ 88.560547] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB3

… it then diconnects within 6 minutes:

[ 345.806966] usb 1-1.3: USB disconnect, device number 8
[ 345.812814] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0

I see there's a USB hub involved. Is that how you're attaching the modem to the router?

In general, you want to provide as much power as possible to the modem and anything between the router and the modem reduces that.

gabe1475
Posts: 32
Joined: Wed Aug 18, 2021 9:12 am
Has thanked: 1 time
Been thanked: 4 times

Re: No Modem Present

Post by gabe1475 » Fri Oct 08, 2021 2:13 pm

LoveMeSomeCALTE wrote:
Fri Oct 08, 2021 11:42 am
The modem connects within 2 minutes of your bootup:

[ 88.560547] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB3

… it then diconnects within 6 minutes:

[ 345.806966] usb 1-1.3: USB disconnect, device number 8
[ 345.812814] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0

I see there's a USB hub involved. Is that how you're attaching the modem to the router?

In general, you want to provide as much power as possible to the modem and anything between the router and the modem reduces that.
I saw something about a usb error in the log. Which is not used. The modem is installed inside using a pci express slot. Nothing is plugged in outside of Ethernet for wireless.

LoveMeSomeCALTE
Posts: 236
Joined: Sun Jul 05, 2020 2:29 pm
Has thanked: 235 times
Been thanked: 27 times

Re: No Modem Present

Post by LoveMeSomeCALTE » Fri Oct 08, 2021 2:23 pm

For now don't connect anything to the router except the modem and restart the system.

Does the modem have a microUSB connector?

An actual set of pictures would help us understand the details.

gabe1475
Posts: 32
Joined: Wed Aug 18, 2021 9:12 am
Has thanked: 1 time
Been thanked: 4 times

Re: No Modem Present

Post by gabe1475 » Fri Oct 08, 2021 3:47 pm

LoveMeSomeCALTE wrote:
Fri Oct 08, 2021 2:23 pm
For now don't connect anything to the router except the modem and restart the system.

Does the modem have a microUSB connector?

An actual set of pictures would help us understand the details.
Its the NEXQ6GO-U sold by LTE Fix. Basically purchased about 2 months ago, so fairly new. No Micro USB connector on this unit. If I don't connect my ubiquity (POE through injector) I cant connect to the device as I am using wireless signal to connect. I can post pics if necessary, is there something specific that you would like to see?

LoveMeSomeCALTE
Posts: 236
Joined: Sun Jul 05, 2020 2:29 pm
Has thanked: 235 times
Been thanked: 27 times

Re: No Modem Present

Post by LoveMeSomeCALTE » Fri Oct 08, 2021 9:12 pm

I see - might want to message the admins/LTEFix to look into your issue. I am not an LTEFix employee and unfamiliar with the NEXQ6GO-U sold by LTE Fix

Post Reply