WG1608D-M, Quectel EM160R-GL, Calyx not staying connected

Hotspots and Dongles related Topics
Post Reply
Reuleaux
Posts: 2
Joined: Fri Apr 16, 2021 1:09 pm
Has thanked: 0
Been thanked: 1 time

WG1608D-M, Quectel EM160R-GL, Calyx not staying connected

Post by Reuleaux » Fri Apr 16, 2021 1:25 pm

I'm having a problem staying connected for more than a couple of minutes.

The Calyx SIM works fine in the provided LinkZone 2 hotspot.

I've tried WiFiX-WG1608-GO2021-02-21-19076.bin and openwrt-WG1608-GO2021-01-06-upgrade.bin firmware. The status in the GUI is different but the same basic problem exists in both. I'm able to connect and get ~100mbps down / 20mbps up but it stops working after just a few minutes.

With the WiFix Firmware the Status remains a SPRINT and it still has a 48.x IP but it just stops passing traffic.

With the GO Firmware the Status reverts to Connecting and the IMEI switches to unknown.

I'm pretty new to these cellular cards but not networking or Linux. I was suspecting a bad SIM card connection, running AT+SIMI results in Error 3 when the connection is not working. If I wiggle the SIM card tray and can get AT+SIMI to respond it usually starts working again for a few minutes. I can't explain why the connection to the SIM might stop working, contently after a few minutes when nothing is moving or being bumped on my desk.

Thereare some of the AT command logs belowwhen it goes from working to no working. How do I get the full logs once they scroll off the webUI? It doesn't see to be consistent what command makes it stop working but you can see below that a simple signal strength check AT+QRSRP fails.

Any help would be appreciated.



OK
AT+QCAINFO
OK
AT+QCFG="nwscanmode"
ERROR
AT+QNWPREFCFG="mode_pref"
+QNWPREFCFG: "mode_pref",AUTO
OK
AT+QTEMP
+QTEMP: "aoss-usr","39"
+QTEMP: "mdm-q6-usr","41"
+QTEMP: "ddrss-usr","40"
+QTEMP: "cpu-usr","41"
+QTEMP: "mdm-core-usr","41"
+QTEMP: "xo-therm-adc","38"
+QTEMP: "pa-therm1-adc","37"
+QTEMP: "mdm-case-therm-adc","38"
OK

Fri Apr 16 18:00:09 2021 : /dev/ttyUSB2 AT+CREG=2;+CREG?;+CREG=0
+CREG: 2,0
OK
AT+CEREG=2;+CEREG?;+CEREG=0
+CEREG: 2,0
OK
AT+C5GREG=2;+C5GREG?;+C5GREG=0

Fri Apr 16 18:00:14 2021 : /dev/ttyUSB2 AT+CSQ
+CSQ: 20,99
OK
AT+QENG="servingcell"
+QENG: "servingcell","LIMSRV","WCDMA",310,410,84C2,DB050C,4383,271,1,-73,-2,-,-,-,-,-
OK
AT+QRSRP
ERROR
AT+QCAINFO
ERROR
AT+QCFG="nwscanmode"
ERROR
AT+QNWPREFCFG="mode_pref"
+QNWPREFCFG: "mode_pref",AUTO
OK
AT+QTEMP
+QTEMP: "aoss-usr","38"
+QTEMP: "mdm-q6-usr","39"
+QTEMP: "ddrss-usr","38"
+QTEMP: "cpu-usr","39"
+QTEMP: "mdm-core-usr","39"
+QTEMP: "xo-therm-adc","36"
+QTEMP: "pa-therm1-adc","36"
+QTEMP: "mdm-case-therm-adc","36"
OK

User avatar
Didneywhorl
Posts: 2160
Joined: Fri Mar 23, 2018 5:37 pm
Location: USA
Has thanked: 743 times
Been thanked: 452 times
Contact:

Re: WG1608D-M, Quectel EM160R-GL, Calyx not staying connected

Post by Didneywhorl » Fri Apr 16, 2021 3:38 pm

Honestly it sounds like you need a brand new SIM card. Call Sprint Business, they can help. Should be very easy. Do not call Calyx or PCsforPeople. they are zero help on stuff like this. They will say you have to buy a new hotspot in many cases.

I could be wrong though.

Reuleaux
Posts: 2
Joined: Fri Apr 16, 2021 1:09 pm
Has thanked: 0
Been thanked: 1 time

Re: WG1608D-M, Quectel EM160R-GL, Calyx not staying connected

Post by Reuleaux » Fri Apr 16, 2021 11:27 pm

Thanks, FWIW, the SIM is essentially brand new but it does seem like something is off with it.

d112014
Posts: 3
Joined: Mon Jun 07, 2021 12:00 pm
Has thanked: 0
Been thanked: 0

Re: WG1608D-M, Quectel EM160R-GL, Calyx not staying connected

Post by d112014 » Mon Jun 07, 2021 12:09 pm

hi Reuleaux, any progress.

I'm also having very similar issue, that the connection drops at 2min mark. My setup:
WG3526 + EM160R-GL (firmware: A07) on minipci to m.2 card using Calyx sim with GlobalOrb firmware dated 5/12.
The AT command debug log pattern is similar. Didnt notice anything obvious in the other logs (kernal, system, etc).

Interestingly, if when I substitute the same SIM in EC25 (that has mini-pci interface) in above setup, the connection is solid.

Something about the EM160R-GL using Calyx SIM doesnt seem to work.

Any pointers is fully appreciated.

Post Reply