T77W968 DW5821e and T-Mobile One/Magenta plan, not compatible?

Related to Modems, Hotspots, Dongles ONLY
User avatar
BillA
Posts: 683
Joined: Sun Dec 01, 2019 6:46 pm
Location: USA
Has thanked: 111 times
Been thanked: 79 times
Contact:

Re: T77W968 DW5821e and T-Mobile One/Magenta plan, not compatible?

Post by BillA » Fri Feb 21, 2020 4:50 pm

tambutso wrote:
Fri Feb 21, 2020 1:09 pm
thank you for the updates.will be testing this. I always thought the ROOter APN setting was able to do this, which is what I did prior to these suggestions. will be testing and get back with results

update: I don't understand what's going on here. Now when I check status, the modem is no longer giving me a response.I have found the thread on flashing firmware on this thing on Linux and I think that is my only option left.

It's possible that the router's firmware doesn't have the proper drivers for this particular modem, or it's sending the wrong APN command, however you can correct that with the previously posted CGDCONT commands.
If you're not getting any response from the modem, make sure you're sending the AT command to the proper port. Some modems created multiple "diag" and "modem" ports in device manger so you'll just have to try sending an "AT" alone multiple times to each port to see which one responds (that is if you have the modem in an external usb adapter). If it's inside the router and not getting any response, try repowering the router a couple of times.
Keep in mind, trying to use "cheap" laptop branded modems will likely give you headaches, thus it's best to stick with true and tried models like the Sierra MC7455/EM7511/EM7565 or Quectel EC25-AF/EP06-A/EM12G etc.
These users thanked the author BillA for the post:
tambutso (Fri Feb 21, 2020 6:50 pm)

tambutso
Posts: 24
Joined: Wed Dec 25, 2019 4:37 pm

Re: T77W968 DW5821e and T-Mobile One/Magenta plan, not compatible?

Post by tambutso » Fri Feb 21, 2020 6:50 pm

so I have better success in Windows 10, and I am able to see that you guys are right. In the properties of this modem, there is no LTE APN programmed. There is no option for me to edit or put in one. Although I can add an Internet APN. for some reason even if I did add in the T-Mobile APN (fast.t-mobile.com), it still will not give me a connection. I do see a few COM ports, I have an application COM, NMEA COM and Diagnostic COM.

On Windows, how does one issue AT commands to the modem? I read something about Putty. I did serial, picked the Application COM, and baud set to 9600 (I think). I am stuck to a terminal with no way for me to input anything.

Also, If I do manage to program the APN in there, will that survive a reboot or a power cycle?

Thank you. I am confident now that the issue is the blank/missing APN in the module. Just getting in there is the issue. Will try the router again if I get any success that I had earlier.

User avatar
BillA
Posts: 683
Joined: Sun Dec 01, 2019 6:46 pm
Location: USA
Contact:

Re: T77W968 DW5821e and T-Mobile One/Magenta plan, not compatible?

Post by BillA » Fri Feb 21, 2020 7:17 pm

tambutso wrote:
Fri Feb 21, 2020 6:50 pm
so I have better success in Windows 10, and I am able to see that you guys are right. In the properties of this modem, there is no LTE APN programmed. There is no option for me to edit or put in one. Although I can add an Internet APN. for some reason even if I did add in the T-Mobile APN (fast.t-mobile.com), it still will not give me a connection. I do see a few COM ports, I have an application COM, NMEA COM and Diagnostic COM.

On Windows, how does one issue AT commands to the modem? I read something about Putty. I did serial, picked the Application COM, and baud set to 9600 (I think). I am stuck to a terminal with no way for me to input anything.

Also, If I do manage to program the APN in there, will that survive a reboot or a power cycle?

Thank you. I am confident now that the issue is the blank/missing APN in the module. Just getting in there is the issue. Will try the router again if I get any success that I had earlier.

In Windows go to Device Manger > right click Modems > Properties > Advanced > Extra Initialization Commands > copy and paste this line:

AT+CGDCONT=1,"IP","fast.t-mobile.com"

Disconnect then reconnect the modem.
Set up a dialup connection in Windows Networking using the dialing number: *99#
Try to connect using the dial-up connection.
If it works, then you're good to go, otherwise check to see if the APN has in fact changed to "fast.t-mobile.com"
Go to any terminal and send this command to the MODEM port right AFTER a dialing attempt (do not reset/restart the modem):

AT+CGDCONT?

The router sends the APN a little differently, so try to see if you can at least connect in Windows first.

OptimusPrime
Posts: 6
Joined: Wed Jan 29, 2020 10:39 pm

Re: T77W968 DW5821e and T-Mobile One/Magenta plan, not compatible?

Post by OptimusPrime » Mon Mar 23, 2020 8:34 pm

Were you able to get this to work?

tambutso
Posts: 24
Joined: Wed Dec 25, 2019 4:37 pm

Re: T77W968 DW5821e and T-Mobile One/Magenta plan, not compatible?

Post by tambutso » Wed Apr 08, 2020 6:26 am

unfortuntely no. I am still looking for solutions to make this card work with T-Mobile. Seller stated this should be an unlocked card, but there is no way for me to tell. I am hoping I could get this flashed to the latest generic firmware, hoping that would work.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post