Quectel EM160R-GL w/ Visible Stopped Working

Related to Modems, Hotspots, Dongles ONLY
Post Reply
cameroooo
Posts: 4
Joined: Sat Oct 09, 2021 11:44 pm
Has thanked: 0
Been thanked: 1 time

Quectel EM160R-GL w/ Visible Stopped Working

Post by cameroooo » Sun Oct 10, 2021 10:17 am

I have a Quectel EM160R-GL that I have been using with a GL.iNET GL-B1300 router and Visible service.

The issue started after I switched to an AT&T sim for a week. Upon switching back to Visible, I was no longer able to get service. The Visible sim still works in my iphone and when I use my EP-06 modem attached to the same router.

As you can see from the below pics, it appears I am connected to the network but I can not get service. Any insight or help would be greatly appreciated.
Screenshot 2021-10-10 110527.jpg
Screenshot 2021-10-10 110439.jpg
Screenshot 2021-10-10 110551.jpg

cameroooo
Posts: 4
Joined: Sat Oct 09, 2021 11:44 pm
Has thanked: 0
Been thanked: 1 time

Re: Quectel EM160R-GL w/ Visible Stopped Working

Post by cameroooo » Tue Oct 12, 2021 9:34 pm

I've done some additional testing using Mint as the cell provider and am still getting the same results. The modem connects to the provider but will not access the internet.

Any insight anyone is able to provide would be greatly appreciated. I am stumped.

User avatar
Didneywhorl
Posts: 2595
Joined: Fri Mar 23, 2018 5:37 pm
Location: USA
Has thanked: 987 times
Been thanked: 556 times
Contact:

Re: Quectel EM160R-GL w/ Visible Stopped Working

Post by Didneywhorl » Wed Oct 13, 2021 12:15 pm

Have you tried resetting the modem?

Should be AT+QPRTPARA=3 then after it reboots AT+QPRTPARA=1

cameroooo
Posts: 4
Joined: Sat Oct 09, 2021 11:44 pm
Has thanked: 0
Been thanked: 1 time

Re: Quectel EM160R-GL w/ Visible Stopped Working

Post by cameroooo » Wed Oct 13, 2021 1:24 pm

Thank you. That seems to have resolved it.

I was only using AT+QPRTPARA=3 previously. Never followed it with AT+QPRTPARA=1

Thanks again. I really appreciate the help. Was driving me nuts

User avatar
Didneywhorl
Posts: 2595
Joined: Fri Mar 23, 2018 5:37 pm
Location: USA
Has thanked: 987 times
Been thanked: 556 times
Contact:

Re: Quectel EM160R-GL w/ Visible Stopped Working

Post by Didneywhorl » Wed Oct 13, 2021 5:40 pm

Trust me, I understand that particular frustration. I had to figure out on my own that AT+QPRTPARA=1 makes the modem begin saving settings changes to the NVRAM. Until then it will not save a thing.

Post Reply