WE826 and EM7355 (DW5808e/2NDHX) Issues

Sierra Wireless AirPrime Modem Card Topics
Post Reply
User avatar
terryjett
Posts: 52
Joined: Tue Sep 24, 2019 10:42 pm
Location: West Tawakoni

WE826 and EM7355 (DW5808e/2NDHX) Issues

Post by terryjett » Sat Nov 09, 2019 10:07 am

I took the plunge and started learning about changing vendor cards to work with WE826/GoldenOrb. Not that easy:) Sure it will get easier, but starting out can be a learning curve.

Used Ubuntu to work with the card and seemed to go pretty well after getting the correct linux software packages onto linux machine.

Popped the converted EM7355 into WE826. I can communicate with the card using at commands but would not connect to carrier (at&t)...

Debug shows this:

Code: Select all

Sat Nov  9 01:01:27 2019 : /dev/ttyUSB2 AT+CFUN=1
ERROR
  
Sat Nov  9 01:01:32 2019 : /dev/ttyUSB2 AT+CMGS=?;+CMGL=?;+CMGR=?
+CMGL: (0-5)
OK
  
Sat Nov  9 01:01:33 2019 : /dev/ttyUSB2 AT+CMGF=0
OK
  
Sat Nov  9 01:01:36 2019 : /dev/ttyUSB2 AT+CPMS="SM","SM","SM"
+CPMS: 1,30,1,30,1,30
OK
  
Sat Nov  9 01:01:38 2019 : /dev/ttyUSB2 AT+CPMS="ME"
+CPMS: 0,23,1,30,1,30
OK
  
Sat Nov  9 01:01:40 2019 : /dev/ttyUSB2 AT+CPMS="SM"
+CPMS: 1,30,1,30,1,30
OK
  
Sat Nov  9 01:01:42 2019 : /dev/ttyUSB2 AT+CMGL=4
OK
  
Sat Nov  9 01:01:47 2019 : /dev/ttyUSB2 AT+CPMS="SM"
+CPMS: 1,30,1,30,1,30
OK
  
Sat Nov  9 01:02:01 2019 : /dev/ttyUSB2 AT+COPS=0,,,7
OK
  
Sat Nov  9 01:02:03 2019 : /dev/ttyUSB2 AT+CGDCONT=?
+CGDCONT: (1-16),"IP",,,(0-2),(0-4)
+CGDCONT: (1-16),"PPP",,,(0-2),(0-4)
+CGDCONT: (1-16),"IPV6",,,(0-2),(0-4)
+CGDCONT: (1-16),"IPV4V6",,,(0-2),(0-4)
OK
  
Sat Nov  9 01:02:04 2019 : /dev/ttyUSB2 AT+CGDCONT?;+CFUN?
+CGDCONT: 1,"IPV4V6","broadband","0.0.0.0",0,0
+CFUN: 0
OK
  
Sat Nov  9 01:02:05 2019 : /dev/ttyUSB2 AT+CFUN=1
ERROR
  
Sat Nov  9 01:02:08 2019 : /dev/ttyUSB2 AT+CPMS="SM"
+CPMS: 1,30,1,30,1,30
OK
I did notice this:

Code: Select all

Modem : Sierra Wireless, Incorporated EM7355 Modem #1		
Modem ID : 1199 : 68a2
Provider : Connection Failed, Retrying...
Comm Port : /dev/ttyUSB2
My working MC7700 is using /dev/ttyUSB3 and wondering if the comm port could be issue with EM7355?

User avatar
JimHelms
Site Admin
Posts: 855
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: WE826 and EM7355 (DW5808e/2NDHX) Issues

Post by JimHelms » Sun Nov 10, 2019 5:25 am

It appears the proper com port is being used since commands are being received and returned by the modem.

What does the following AT Command return:

Code: Select all

AT!USBINFO?
I seem to remember something about the vendor branded EM7XXX modems and the PCFCCAUTH (FCC authorization) placing the modem in LowPowerMode.

If the command does not return a LowPowerMode, then I would try MODIFYING the way GoldenOrb is sending the APN from a IPV4V6 to a IPV4 APN.

User avatar
terryjett
Posts: 52
Joined: Tue Sep 24, 2019 10:42 pm
Location: West Tawakoni

Re: WE826 and EM7355 (DW5808e/2NDHX) Issues

Post by terryjett » Sun Nov 10, 2019 8:53 am

Thanks Jim!

I have already had to return my WE826 back to MC7700 as only internet at the moment.

But, when running at!gstatus? during testing, recall seeing "LowPowerMode" in results. Not sure what that means?

User avatar
JimHelms
Site Admin
Posts: 855
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: WE826 and EM7355 (DW5808e/2NDHX) Issues

Post by JimHelms » Sun Nov 10, 2019 10:15 am

I would review THIS article and the lower portion of THIS one.

User avatar
terryjett
Posts: 52
Joined: Tue Sep 24, 2019 10:42 pm
Location: West Tawakoni

Re: WE826 and EM7355 (DW5808e/2NDHX) Issues

Post by terryjett » Sun Nov 10, 2019 2:53 pm

Thanks Jim! Yes, I briefly looked at one of those links last night. Tried some of the steps this morning with no luck.

Will give it a shot later. Maybe this oem version is not worth messing with.

User avatar
JimHelms
Site Admin
Posts: 855
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: WE826 and EM7355 (DW5808e/2NDHX) Issues

Post by JimHelms » Sun Nov 10, 2019 3:04 pm

terryjett wrote:
Sun Nov 10, 2019 2:53 pm

Will give it a shot later. Maybe this oem version is not worth messing with.
Just depends on how much spare time you have on your hands.

There are a lot of people doing these conversions but I don't really mess with them so I am little help on the subject.

User avatar
terryjett
Posts: 52
Joined: Tue Sep 24, 2019 10:42 pm
Location: West Tawakoni

Re: WE826 and EM7355 (DW5808e/2NDHX) Issues

Post by terryjett » Sun Nov 10, 2019 3:14 pm

Just depends on how much spare time you have on your hands.
LOL, got lots of time these days, but think there are easier cards to convert. Did a EM7455 in 20 minutes. Not a lot of difference in used pricing for EM7355 and 7455.

Not one to give up very easy, but currently only have one WE826, , adapter and at&t account. Going to wait until funding comes around for another setup to play with:)

User avatar
terryjett
Posts: 52
Joined: Tue Sep 24, 2019 10:42 pm
Location: West Tawakoni

Re: WE826 and EM7355 (DW5808e/2NDHX) Issues

Post by terryjett » Sun Nov 10, 2019 11:27 pm

Seems some of the EM7355 OEM versions are locked into low power mode after modifying. You will need to use a "OpenMEP Generator" type software, but appears the method recently changed by SW. There is some software for this purpose but it no longer works.

Think there is an update forthcoming, so until then - these types of cards are stuck in low power mode after changing vid/pid.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post