EM7565 QMI mode?

Sierra Wireless AirPrime Modem Card Topics
Post Reply
swwifty
Posts: 414
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

EM7565 QMI mode?

Post by swwifty » Mon Jul 15, 2019 2:36 pm

I tried to put my EM7565 in QMI mode for some testing (it was in MBIM) now GoldenOrb can't talk to the modem. I see it pop up and is detected by the kernel, but I can't talk to it.

I ran the following command to put it in QMI mode:

at!usbcomp=1,1,10d

Any ideas how to rescue my modem? I'm thinking slap it into my Linux laptop and send some at commands to change it back, but not sure what tools I can use to do that.

swwifty
Posts: 414
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: EM7565 QMI mode?

Post by swwifty » Mon Jul 15, 2019 3:17 pm

well I got it out of QMI mode via my Linux laptop, but its still not working.....

User avatar
JimHelms
Site Admin
Posts: 739
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: EM7565 QMI mode?

Post by JimHelms » Mon Jul 15, 2019 3:21 pm

swwifty wrote:
Mon Jul 15, 2019 2:36 pm
I tried to put my EM7565 in QMI mode for some testing (it was in MBIM) now GoldenOrb can't talk to the modem. I see it pop up and is detected by the kernel, but I can't talk to it.

I ran the following command to put it in QMI mode:

at!usbcomp=1,1,10d

Any ideas how to rescue my modem? I'm thinking slap it into my Linux laptop and send some at commands to change it back, but not sure what tools I can use to do that.
That is the wrong command for QMI on the EM7565. It takes:

Code: Select all

at!usbcomp=1,3,10d

User avatar
JimHelms
Site Admin
Posts: 739
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: EM7565 QMI mode?

Post by JimHelms » Mon Jul 15, 2019 3:22 pm

swwifty wrote:
Mon Jul 15, 2019 3:17 pm
well I got it out of QMI mode via my Linux laptop, but its still not working.....
What are its symptoms?

swwifty
Posts: 414
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: EM7565 QMI mode?

Post by swwifty » Mon Jul 15, 2019 4:26 pm

JimHelms wrote:
Mon Jul 15, 2019 3:22 pm
What are its symptoms?
GoldenOrb just doesn't see the modem, even though it shows up in the kernel logs.

Maybe I issued the wrong command for MBIM mode as well? Although the kernel sees it come up in MBIM currently.

User avatar
JimHelms
Site Admin
Posts: 739
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: EM7565 QMI mode?

Post by JimHelms » Mon Jul 15, 2019 4:28 pm

swwifty wrote:
Mon Jul 15, 2019 4:26 pm
GoldenOrb just doesn't see the modem, even though it shows up in the kernel logs.

Maybe I issued the wrong command for MBIM mode as well? Although the kernel sees it come up in MBIM currently.
That is most likely the issue. MBIM is:

Code: Select all

AT!USBCOMP=1,3,1009

swwifty
Posts: 414
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: EM7565 QMI mode?

Post by swwifty » Mon Jul 15, 2019 4:36 pm

JimHelms wrote:
Mon Jul 15, 2019 4:28 pm
That is most likely the issue. MBIM is:

Code: Select all

AT!USBCOMP=1,3,1009
OK, trying that now.

swwifty
Posts: 414
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: EM7565 QMI mode?

Post by swwifty » Mon Jul 15, 2019 4:39 pm

That fixed it, apparently at!usbcomp=1,1,10d or at!usbcomp=1,1,1009 only works on MC7455 modems.

Strange thing is, it said in the kernel output it was in MBIM and QMI mode the whole time.

User avatar
JimHelms
Site Admin
Posts: 739
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: EM7565 QMI mode?

Post by JimHelms » Mon Jul 15, 2019 4:59 pm

swwifty wrote:
Mon Jul 15, 2019 4:39 pm
That fixed it, apparently at!usbcomp=1,1,10d or at!usbcomp=1,1,1009 only works on MC7455 modems.

Strange thing is, it said in the kernel output it was in MBIM and QMI mode the whole time.
It is, only it removes the modem WAN port.

swwifty
Posts: 414
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: EM7565 QMI mode?

Post by swwifty » Mon Jul 15, 2019 6:12 pm

JimHelms wrote:
Mon Jul 15, 2019 4:59 pm
It is, only it removes the modem WAN port.
Thanks for the help Jim.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post