Occasional disconnects we826 mc7455

Topics related to OpenWRT, LEDE, GoldenOrb, Linux and other firmware
Post Reply
User avatar
BrentV
Posts: 4
Joined: Mon Jun 17, 2019 11:26 am

Occasional disconnects we826 mc7455

Post by BrentV » Mon Jun 17, 2019 12:34 pm

I just built the we826-T2 + mc7455 combination and installed GoldenOrb_2018-11-03 and AT&T with 2 amp power adapter. The router came from aliexpress with an OEM firmware installed, so I used the firmware recovery mode to flash goldenorb.

I installed the modem before updating the firmware so I ran through each of the AT commands.

Code: Select all

AT!ENTERCND="A710"
AT!RMARESET=1
AT!RESET
The disconnects aren't real frequent and only last a couple mins, but still annoying. Right now I'm primarily testing it with one computer over ethernet and occasionally jump on the wifi with my phone. All settings are default, other than the APN change to broadband for At&t.

After the last disconnect this is what I found in the system log.

Code: Select all

Sun Jun 16 21:51:00 2019 daemon.info dnsmasq-dhcp[2473]: read /etc/ethers - 0 addresses
Mon Jun 17 11:19:48 2019 daemon.warn odhcpd[1300]: DHCPV6 REQUEST IA_NA from 00010001215ca857d8cb8a142553 on br-lan: ok fd09:747a:fdce::4a6/128
Mon Jun 17 11:19:49 2019 daemon.info dnsmasq[2473]: read /etc/hosts - 4 addresses
Mon Jun 17 11:19:49 2019 daemon.info dnsmasq[2473]: read /tmp/hosts/odhcpd - 1 addresses
Mon Jun 17 11:19:49 2019 daemon.info dnsmasq[2473]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Mon Jun 17 11:19:49 2019 daemon.info dnsmasq-dhcp[2473]: read /etc/ethers - 0 addresses
Mon Jun 17 11:19:49 2019 user.notice firewall: Reloading firewall due to ifup of wan1 (wwan0)
Mon Jun 17 11:20:04 2019 user.notice Create Connection: Connected
Mon Jun 17 11:20:05 2019 user.notice Connection Monitor: Start Connection Monitor for Modem 1
Here's the modem firmware

Code: Select all

AT!IMPREF?
!IMPREF: 
 preferred fw version:    02.24.05.06
 preferred carrier name:  GENERIC
 preferred config name:   GENERIC_002.026_000
 current fw version:      02.24.05.06
 current carrier name:    GENERIC
 current config name:     GENERIC_002.026_000

OK


User avatar
JimHelms
Site Admin
Posts: 701
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: Occasional disconnects we826 mc7455

Post by JimHelms » Mon Jun 17, 2019 4:38 pm

I would first disable Connection Monitoring and see if that solves your issue.

Next, need to look at your signals. Run the command:

Code: Select all

AT!GSTATUS?

User avatar
BrentV
Posts: 4
Joined: Mon Jun 17, 2019 11:26 am

Re: Occasional disconnects we826 mc7455

Post by BrentV » Thu Jun 20, 2019 12:41 pm

Connection monitoring was never enabled. Signal seems ok. For the most part the disconnects aren't too bad, maybe once a day. But I have noticed a disconnect here and there more so than with my Mofi.

Code: Select all

AT!GSTATUS?
!GSTATUS: 
Current Time:  292		Temperature: 49
Reset Counter: 27		Mode:        ONLINE         
System mode:   LTE        	PS state:    Attached     
LTE band:      B5     		LTE bw:      10 MHz  
LTE Rx chan:   2501		LTE Tx chan: 20501
LTE CA state:  INACTIVE    		LTE Scell band:B2     
LTE Scell bw:5 MHz   		LTE Scell chan:925
EMM state:     Registered     	Normal Service 
RRC state:     RRC Connected  
IMS reg state: No Srv  		

PCC RxM RSSI:  -75		RSRP (dBm):  -101
PCC RxD RSSI:  -70		RSRP (dBm):  -94
SCC RxM RSSI:  -72		RSRP (dBm):  -100
SCC RxD RSSI:  -69		RSRP (dBm):  -100
Tx Power:      8		TAC:         700F (28687)
RSRQ (dB):     -9.9		Cell ID:     0C8C23CB (210510795)
SINR (dB):     15.4

zeppelin58
Posts: 1
Joined: Fri Aug 02, 2019 9:40 am

Re: Occasional disconnects we826 mc7455

Post by zeppelin58 » Fri Aug 02, 2019 9:48 am

I had this problem but mine was disconnecting several times a day. I bought this adapter https://ltefix.com/shop/pcie-m-2/usb-to ... aight-sim/ and flashed the latest sierra wireless generic firmware on my mc7455. Problem solved! Been over a week and I have not had a single disconnect.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post