ZBT WG1608, EM20-G, Page Plus, stuck connecting

Topics related to OpenWRT, LEDE, GoldenOrb, Linux and other firmware
User avatar
Didneywhorl
Posts: 1293
Joined: Fri Mar 23, 2018 5:37 pm
Location: USA
Has thanked: 361 times
Been thanked: 219 times
Contact:

Re: ZBT WG1608, EM20-G, Page Plus, stuck connecting

Post by Didneywhorl » Wed Nov 11, 2020 8:57 pm

Have you tried Visible? Also you may want to try changing the modems protocol from QMI to MBIM or even to ECM. Whatever its set to, try changing it. Also remember you really need to fully power the router down between settings changes.
The Solution for your Internet Connectivity and Speed.

mrconnerton
Posts: 6
Joined: Tue Aug 18, 2020 12:56 pm
Has thanked: 0
Been thanked: 0

Re: ZBT WG1608, EM20-G, Page Plus, stuck connecting

Post by mrconnerton » Thu Nov 12, 2020 9:59 am

I have not tried Visible.

Can you point me to some posts on changing protocol from QMI to MBIM or even to ECM.

bcd1975
Posts: 16
Joined: Thu Jan 23, 2020 4:27 pm
Has thanked: 0
Been thanked: 1 time

Re: ZBT WG1608, EM20-G, Page Plus, stuck connecting

Post by bcd1975 » Thu Nov 12, 2020 10:57 pm

Set Connection Modes

QMI/PPP/Default
AT+QCFG="usbnet",0

ECM
AT+QCFG="usbnet",1

MBIM
AT+QCFG="usbnet",2

User avatar
Didneywhorl
Posts: 1293
Joined: Fri Mar 23, 2018 5:37 pm
Location: USA
Has thanked: 361 times
Been thanked: 219 times
Contact:

Re: ZBT WG1608, EM20-G, Page Plus, stuck connecting

Post by Didneywhorl » Fri Nov 13, 2020 7:59 pm

Try ECM last if needed or wanting. It sometimes requires sorcery to get back. Not always, but sometimes.
The Solution for your Internet Connectivity and Speed.

Post Reply