Sprint and EM7455 - solution to disconnects?

Related to Router Devices ONLY
sporez
Posts: 3
Joined: Fri Jun 14, 2019 12:18 pm

Sprint and EM7455 - solution to disconnects?

Post by sporez » Thu Jul 25, 2019 5:54 pm

I purchased a Sprint unlimited sim/hotspot through one of the Mobile Citizen vendors. Hoping to be able to use it in my em7455, however after experimenting for a while I seem to suffer from the frequent disconnects/instability that so many others have. I've read many threads on the issue and they all seem to go dead without any resolution to the problem.

Is there a reliable way to run a Sprint sim in the MC/EM 7455 with generic fw without disconnecting? It seems when locking to B25 it works better, but speeds are slow (10-15mbps) so not very useful. B41 CAx2 gets really good speeds (50-70mbps) but will seemingly disconnect in 30-60ish minutes and internet comes grinding to a halt until resetting the modem. Very frustrating.

FraCanTob
Posts: 8
Joined: Tue Apr 02, 2019 7:31 pm

Re: Sprint and EM7455 - solution to disconnects?

Post by FraCanTob » Sat Jul 27, 2019 4:52 am

I would very much like to hear about the latest on this issue too (Sprint here as well, but I use an MC7455). Last I checked was a few months ago, and I came to the same conclusion--nobody has been able to figure it out.

sporez
Posts: 3
Joined: Fri Jun 14, 2019 12:18 pm

Re: Sprint and EM7455 - solution to disconnects?

Post by sporez » Mon Jul 29, 2019 9:00 pm

FraCanTob wrote:
Sat Jul 27, 2019 4:52 am
I would very much like to hear about the latest on this issue too (Sprint here as well, but I use an MC7455). Last I checked was a few months ago, and I came to the same conclusion--nobody has been able to figure it out.
Are you running sprint currently? How do you deal with the weird instability?

FraCanTob
Posts: 8
Joined: Tue Apr 02, 2019 7:31 pm

Re: Sprint and EM7455 - solution to disconnects?

Post by FraCanTob » Wed Jul 31, 2019 9:49 am

I am running Sprint right now. And right now, I just put up with the ~hourly disconnects!

FraCanTob
Posts: 8
Joined: Tue Apr 02, 2019 7:31 pm

Re: Sprint and EM7455 - solution to disconnects?

Post by FraCanTob » Thu Aug 01, 2019 9:13 am

It might be that Mchccjg12 over on the Whirlpool ROOter thread is on to something: https://forums.whirlpool.net.au/forum-r ... &ux=821957

He says:
susndic writes:
I'm on the the latest March GoldenOrb, on a GLinet X750, and MC7455 on QMI mode. Whenever I change LTE bands (because I'm moving around), it'll disconnect. I've narrowed it down to the DHCP on WAN1 not reconnecting to fetch a new IP address.

I've found the same thing, and I think it's why Sprint seems to disconnect so much as well... at least, it's part of the reason. The interface doesn't update to the new assigned IP address, so it usually will restart the whole modem... if there was a way to get it to recognize the new IP, it wouldn't need to reboot the modem so often.

Mchccjg12
Posts: 9
Joined: Tue Sep 18, 2018 6:40 pm

Re: Sprint and EM7455 - solution to disconnects?

Post by Mchccjg12 » Fri Aug 02, 2019 9:48 pm

From what I can tell, it's an issue on Sprint's end with the way their terrible equipment works. Even with the EM7565, it will disconnect upon changing bands or cells because it will change IP every time. I am pretty sure it works with other carriers because they handle it better on the network end.

sporez
Posts: 3
Joined: Fri Jun 14, 2019 12:18 pm

Re: Sprint and EM7455 - solution to disconnects?

Post by sporez » Sat Aug 03, 2019 5:48 pm

This is interesting. But would this explain why the problem happens with the modem sitting still in my house sitting on B41? Even when it's locked to that band it still suffers the disconnects.

FraCanTob
Posts: 8
Joined: Tue Apr 02, 2019 7:31 pm

Re: Sprint and EM7455 - solution to disconnects?

Post by FraCanTob » Sun Aug 04, 2019 9:45 am

I think it's interesting that it's no problem for the devices supplied with Sprint SIMs, e.g. R850. Why would that be?

Concerning being locked to B41, I think there's more to it than that. You can restrict the device to B41, but it still connects to different towers, or different parts of B41 on a single tower, or something along those lines. As each of those changes happen, you get a disconnect.

Mchccjg12
Posts: 9
Joined: Tue Sep 18, 2018 6:40 pm

Re: Sprint and EM7455 - solution to disconnects?

Post by Mchccjg12 » Tue Aug 06, 2019 1:31 am

Yeah, pretty much. I think it also has to do with a ton of issues inherent with their towers too. As I will even get disconnects on my EM7565. I think it drops the connection to one part of the tower, and the modem tries to connect to another channel, causing the disconnect. Other modems probably handle the issue better, or there's something that happens in the firmware that the EM7565 and the MC7455 are missing.

FraCanTob
Posts: 8
Joined: Tue Apr 02, 2019 7:31 pm

Re: Sprint and EM7455 - solution to disconnects?

Post by FraCanTob » Wed Aug 07, 2019 2:18 am

@Mchccjg12, do you notice the EM7565 is markedly better than the 7455? Is there any modem out there that doesn't have this problem with Sprint that we could use in a similar way?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post