WE1326 cant connect to 5G WiFi

Related to Router Devices ONLY
User avatar
JimHelms
Site Admin
Posts: 771
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: WE1326 cant connect to 5G WiFi

Post by JimHelms » Wed Jul 17, 2019 3:53 pm

The Pre-V5 versions are 512MB memory where the V5 is 256MB.

The manufacturer made the changes and never informed us of the change. We were unaware of the change until someone tired flashing the router with GoldenOrb. We then had to have a new V5 firmware compiled.

The V5 firmware will upload on the pre-V5 version, but not the other way around.

Lbnaz
Posts: 52
Joined: Thu May 09, 2019 10:02 am

Re: WE1326 cant connect to 5G WiFi

Post by Lbnaz » Wed Jul 17, 2019 4:00 pm

Jim,
Based on the Status screen it looks to me to be a V5.
RouterStatus.JPG
Firmware I used "openwrt-we1326v5-GO2019-04-10-upgrade.bin"
I could try the pre V5 firmware, nothing to lose at this point.
Thanks

xdavidx
Posts: 267
Joined: Tue May 28, 2019 4:04 pm

Re: WE1326 cant connect to 5G WiFi

Post by xdavidx » Wed Jul 17, 2019 4:06 pm

JimHelms wrote:
Wed Jul 17, 2019 3:53 pm
The Pre-V5 versions are 512MB memory where the V5 is 256MB.
Going backwards was nice of them. Are there any features that they had to chop out of GoldenOrb for the V5 version?

xdavidx
Posts: 267
Joined: Tue May 28, 2019 4:04 pm

Re: WE1326 cant connect to 5G WiFi

Post by xdavidx » Wed Jul 17, 2019 4:09 pm

Lbnaz wrote:
Wed Jul 17, 2019 4:00 pm
Based on the Status screen it looks to me to be a V5.
Interesting. The memory matches the V5, but the model doesn't say V5 in it. On mine, with the WiFiX/GoldenOrb firmware, the model shows as "WE1326v5".

Unless, if you *do* have a pre-v5, then maybe the firmware is only grabbing 256MB and not showing the rest.

User avatar
JimHelms
Site Admin
Posts: 771
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: WE1326 cant connect to 5G WiFi

Post by JimHelms » Wed Jul 17, 2019 4:25 pm

xdavidx wrote:
Wed Jul 17, 2019 4:06 pm
Going backwards was nice of them. Are there any features that they had to chop out of GoldenOrb for the V5 version?
Yes, that was nice of them and you can rest assured I expressed my feelings in pretty blunt terms.

It remains a constant challenge (to say the least) to deal with some (if not most) of the Asian manufactures and suppliers.

No features were removed from the V5 build.

User avatar
JimHelms
Site Admin
Posts: 771
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: WE1326 cant connect to 5G WiFi

Post by JimHelms » Wed Jul 17, 2019 4:25 pm

xdavidx wrote:
Wed Jul 17, 2019 4:09 pm
Interesting. The memory matches the V5, but the model doesn't say V5 in it. On mine, with the WiFiX/GoldenOrb firmware, the model shows as "WE1326v5".

Unless, if you *do* have a pre-v5, then maybe the firmware is only grabbing 256MB and not showing the rest.
Can you screen shot what your V5 looks like and what is different?

Lbnaz
Posts: 52
Joined: Thu May 09, 2019 10:02 am

Re: WE1326 cant connect to 5G WiFi

Post by Lbnaz » Wed Jul 17, 2019 4:43 pm

Jim,
I tried the Pre V5 firmware once using the firmware update screen. it flashed and when thru I lost ethernet connection and could not connect back up. I then used bootloader to connect back up and flashed again with the pre V5 version.
Same thing happened, I lost ethernet connection and could not connect back up. Back to boot loader and flashed V5. I will try WiFi again but , I think will have the same problem.
So it looks to to me to be a V5.
Thanks for your help

User avatar
JimHelms
Site Admin
Posts: 771
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: WE1326 cant connect to 5G WiFi

Post by JimHelms » Wed Jul 17, 2019 5:08 pm

Lbnaz wrote:
Wed Jul 17, 2019 4:43 pm
I tried the Pre V5 firmware once using the firmware update screen. it flashed and when thru I lost ethernet connection and could not connect back up. I then used bootloader to connect back up and flashed again with the pre V5 version.
This is strange since using the UI to flash a V5 will not allow a pre-V5 firmware to be uploaded. It will literally refuse the bin file.
So it looks to to me to be a V5.
I am not so convinced.

Maybe xdavidx can screen shot the differences he referenced.

xdavidx
Posts: 267
Joined: Tue May 28, 2019 4:04 pm

Re: WE1326 cant connect to 5G WiFi

Post by xdavidx » Wed Jul 17, 2019 5:10 pm

JimHelms wrote:
Wed Jul 17, 2019 4:25 pm
Can you screen shot what your V5 looks like and what is different?
Here it is:

Screenshot_2019-07-17-01-05-17.png
Screenshot_2019-07-17-01-05-17.png (56.8 KiB) Viewed 487 times

Note that it doesn't show the OpenWRT version next to the GoldenOrb version either. My version is one day behind @Lbnaz's firmware.

I can upgrade to 2019-04-10 to see if it still looks different. That would be very telling if it was. Although, I guess I'd have the WiFiX version, so *technically* someone could have slipped in something different vs the GoldenOrb version.

Alternatively, since mine is working fine, @Libnaz, you could try flashing 2019-04-09 of WiFix to see if that changes the behavior and to post the system status screenshot again to compare with mine.

@JimHelms: Is there an issue with keeping settings when upgrading the firmware from GoldenOrb to GoldenOrb? I wasn't sure if that is just an issue when going from apples to oranges or also when upgrading apples to apples+.

User avatar
JimHelms
Site Admin
Posts: 771
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: WE1326 cant connect to 5G WiFi

Post by JimHelms » Wed Jul 17, 2019 5:17 pm

xdavidx wrote:
Wed Jul 17, 2019 5:10 pm

@JimHelms: Is there an issue with keeping settings when upgrading the firmware from GoldenOrb to GoldenOrb? I wasn't sure if that is just an issue when going from apples to oranges or also when upgrading apples to apples+.
In theory, from Apple to Apple, one might be okay as long as the build is configured and working correctly. But then again...if the images were built using different snapshots of the OpenWRT, it could make a difference.

Probably the best practice is to backup and restore the configuration file. And, do not save settings when uploading the firmware.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post