WG3526 Connection Issues

Related to Router Devices ONLY
User avatar
WillTonn
Posts: 25
Joined: Fri Oct 12, 2018 10:09 pm

Re: WG3526 Connection Issues

Post by WillTonn » Tue Oct 30, 2018 10:50 am

I tried the experiment and it doesn't seem to have made it more stable. I'm not sure if the code looks any different.

Code: Select all

Tue Oct 30 10:44:12 2018 daemon.info hostapd: wlan0: STA d8:31:34:29:a8:f1 WPA: group key handshake completed (WPA)
Tue Oct 30 10:45:33 2018 daemon.info odhcpd[902]: Using a RA lifetime of 1800 seconds on br-lan
Tue Oct 30 10:45:46 2018 user.notice MBIM Monitor: Modem 1 Connection is Down (activation state: deactivated)
Tue Oct 30 10:45:52 2018 user.notice Connection Monitor: Modem 1 Connection is Down (using Ping Test)
Tue Oct 30 10:46:03 2018 user.notice Sierra Data: AT+CSQ
+CSQ: 99,99

OK
AT*CNTI=0
+CME ERROR: no network service
AT!SELRAT?
!SELRAT: 06, LTE Only


OK
AT+ECIO?
+ECIO: NOT IMPLEMENTED

OK
AT+RSCP?
+RSCP: NOT IMPLEMENTED

OK
AT!UMTSCHAN?
!UMTSCHAN: NOT IMPLEMENTED

OK
AT!GSTATUS?
!GSTATUS: 
Current Time:  1325		Temperature: 40
Reset Counter: 1		Mode:        LOW POWER MODE 


OK
Tue Oct 30 10:46:06 2018 kern.info kernel: [ 1337.154230] usb 1-2: USB disconnect, device number 2
Tue Oct 30 10:46:06 2018 kern.info kernel: [ 1337.159584] qcserial ttyUSB0: Qualcomm USB modem converter now disconnected from ttyUSB0
Tue Oct 30 10:46:06 2018 kern.info kernel: [ 1337.168076] qcserial 1-2:1.0: device disconnected
Tue Oct 30 10:46:06 2018 kern.info kernel: [ 1337.173770] qcserial ttyUSB1: Qualcomm USB modem converter now disconnected from ttyUSB1
Tue Oct 30 10:46:06 2018 kern.info kernel: [ 1337.182129] qcserial 1-2:1.3: device disconnected
Tue Oct 30 10:46:06 2018 kern.info kernel: [ 1337.187223] cdc_mbim 1-2:1.12 wwan0: unregister 'cdc_mbim' usb-1e1c0000.xhci-2, CDC MBIM
Tue Oct 30 10:46:06 2018 daemon.notice netifd: Network device 'wwan0' link is down
Tue Oct 30 10:46:06 2018 daemon.info odhcpd[902]: Raising SIGUSR1 due to default route change
Tue Oct 30 10:46:06 2018 daemon.info odhcpd[902]: Raising SIGUSR1 due to address change on wwan0
Tue Oct 30 10:46:07 2018 user.notice MBIM Connect: Stopping network
Tue Oct 30 10:46:07 2018 daemon.notice netifd: wan1 (10432): open failed: : No such file or directory
Tue Oct 30 10:46:07 2018 daemon.notice netifd: wan1 (10432): Command failed: Permission denied
Tue Oct 30 10:46:07 2018 daemon.notice netifd: Interface 'wan1' is now down
Tue Oct 30 10:46:07 2018 daemon.info odhcpd[902]: Raising SIGUSR1 due to address change on br-lan
Tue Oct 30 10:46:07 2018 daemon.warn dnsmasq[1476]: no servers found in /tmp/resolv.conf.auto, will retry
Tue Oct 30 10:46:07 2018 daemon.info dnsmasq[1476]: read /etc/hosts - 4 addresses
Tue Oct 30 10:46:07 2018 daemon.info dnsmasq[1476]: read /tmp/hosts/odhcpd - 1 addresses
Tue Oct 30 10:46:07 2018 daemon.info dnsmasq[1476]: read /tmp/hosts/dhcp.cfg02411c - 2 addresses
Tue Oct 30 10:46:07 2018 daemon.info dnsmasq-dhcp[1476]: read /etc/ethers - 0 addresses
Tue Oct 30 10:46:07 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:07 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:07 2018 user.notice usb-modeswitch: * Remove : 1-2 : Modem1
Tue Oct 30 10:46:07 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:07 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:08 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:08 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:08 2018 user.notice usb-modeswitch: * No Modems present
Tue Oct 30 10:46:08 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:08 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:08 2018 daemon.info odhcpd[902]: Using a RA lifetime of 0 seconds on br-lan
Tue Oct 30 10:46:14 2018 kern.info kernel: [ 1344.941256] usb 1-2: new high-speed USB device number 3 using xhci-mtk
Tue Oct 30 10:46:14 2018 kern.warn kernel: [ 1345.081960] usb 1-2: config 1 has an invalid interface number: 12 but max is 3
Tue Oct 30 10:46:14 2018 kern.warn kernel: [ 1345.089284] usb 1-2: config 1 has an invalid interface number: 13 but max is 3
Tue Oct 30 10:46:14 2018 kern.warn kernel: [ 1345.096581] usb 1-2: config 1 has an invalid interface number: 13 but max is 3
Tue Oct 30 10:46:14 2018 kern.warn kernel: [ 1345.103816] usb 1-2: config 1 has no interface number 1
Tue Oct 30 10:46:14 2018 kern.warn kernel: [ 1345.109085] usb 1-2: config 1 has no interface number 2
Tue Oct 30 10:46:14 2018 kern.info kernel: [ 1345.117863] qcserial 1-2:1.0: Qualcomm USB modem converter detected
Tue Oct 30 10:46:14 2018 kern.info kernel: [ 1345.125042] usb 1-2: Qualcomm USB modem converter now attached to ttyUSB0
Tue Oct 30 10:46:14 2018 kern.info kernel: [ 1345.133605] qcserial 1-2:1.3: Qualcomm USB modem converter detected
Tue Oct 30 10:46:14 2018 kern.info kernel: [ 1345.140459] usb 1-2: Qualcomm USB modem converter now attached to ttyUSB1
Tue Oct 30 10:46:14 2018 kern.info kernel: [ 1345.162260] cdc_mbim 1-2:1.12: cdc-wdm0: USB WDM device
Tue Oct 30 10:46:14 2018 kern.info kernel: [ 1345.169488] cdc_mbim 1-2:1.12 wwan0: register 'cdc_mbim' at usb-1e1c0000.xhci-2, CDC MBIM, 06:38:3e:1c:12:00
Tue Oct 30 10:46:14 2018 user.notice Log Print : Driver Name : 1
Tue Oct 30 10:46:14 2018 user.notice Log Print : Driver Name : 2 qcserial
Tue Oct 30 10:46:14 2018 user.notice Log Print : Driver Name : 3 qcserial
Tue Oct 30 10:46:14 2018 user.notice Log Print : Driver Name : 4 cdc_mbim
Tue Oct 30 10:46:14 2018 user.notice Log Print : Driver Name : 5 cdc_mbim
Tue Oct 30 10:46:14 2018 user.notice Log Print : Driver Name : 6 cdc_mbim
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: Add : 1-2: Manufacturer=Sierra_Wireless,_Incorporated Product=Sierra_Wireless_MC7455_Qualcomm®_Snapdragon™_X7_LTE-A Serial=LQ83160778041025 1199 9071
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: * Start of Modem Detection and Connection Information
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: * Product=Sierra_Wireless_MC7455_Qualcomm®_Snapdragon™_X7_LTE-A 1199 9071
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: * Found MBIM Modem at 1-2
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:14 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: * Switched to : 1199:9071
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:24 2018 user.notice Log Print : Driver Name : 1
Tue Oct 30 10:46:24 2018 user.notice Log Print : Driver Name : 2 qcserial
Tue Oct 30 10:46:24 2018 user.notice Log Print : Driver Name : 3 qcserial
Tue Oct 30 10:46:24 2018 user.notice Log Print : Driver Name : 4 cdc_mbim
Tue Oct 30 10:46:24 2018 user.notice Log Print : Driver Name : 5 cdc_mbim
Tue Oct 30 10:46:24 2018 user.notice Log Print : Driver Name : 6 cdc_mbim
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: * ProtoFind returns : 3
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: *
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: *****************************************************************
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: Found Modem1
Tue Oct 30 10:46:24 2018 user.notice usb-modeswitch: Connecting a MBIM Modem
Tue Oct 30 10:46:25 2018 user.notice Create Connection: Start MBIM Connection
Thanks

swwifty
Posts: 414
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: WG3526 Connection Issues

Post by swwifty » Tue Oct 30, 2018 10:59 am

I still think your modem is randomly going into low power mode for some reason, and dropping your connection.

What firmware are you running again, Generic?

Try the following:

Code: Select all

AT!ENTERCND="A710"
AT!IMPREF="GENERIC"
AT!RESET
Also what does the output of the following command show:

Code: Select all

AT!IMPREF?

User avatar
WillTonn
Posts: 25
Joined: Fri Oct 12, 2018 10:09 pm

Re: WG3526 Connection Issues

Post by WillTonn » Tue Oct 30, 2018 11:37 am

Hi. I'm using GoldenOrb_Build2017-12-15.

Code: Select all

AT!IMPREF?
!IMPREF: 
 preferred fw version:    02.24.05.06
 preferred carrier name:  GENERIC
 preferred config name:   GENERIC_002.026_000
 current fw version:      02.24.05.06
 current carrier name:    GENERIC
 current config name:     GENERIC_002.026_000

OK

swwifty
Posts: 414
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: WG3526 Connection Issues

Post by swwifty » Tue Oct 30, 2018 12:39 pm

WillTonn wrote:
Tue Oct 30, 2018 11:37 am
Hi. I'm using GoldenOrb_Build2017-12-15.

Code: Select all

AT!IMPREF?
!IMPREF: 
 preferred fw version:    02.24.05.06
 preferred carrier name:  GENERIC
 preferred config name:   GENERIC_002.026_000
 current fw version:      02.24.05.06
 current carrier name:    GENERIC
 current config name:     GENERIC_002.026_000

OK
I actually meant the firmware of the modem (which is what the AT!IMPREF? command outputs).

Is this the output of that command, after you ran the commands to reset the firmware back to generic that I shared, or did you just run AT!IMPREF?

User avatar
WillTonn
Posts: 25
Joined: Fri Oct 12, 2018 10:09 pm

Re: WG3526 Connection Issues

Post by WillTonn » Tue Oct 30, 2018 12:53 pm

This after I ran the AT!IMPREF="GENERIC" sequence you recommended.

swwifty
Posts: 414
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: WG3526 Connection Issues

Post by swwifty » Tue Oct 30, 2018 1:42 pm

WillTonn wrote:
Tue Oct 30, 2018 12:53 pm
This after I ran the AT!IMPREF="GENERIC" sequence you recommended.
Ok, so it'll be hard to tell if there was a firmware mismatch or not now (thats okay should have told you to run them in the opposite order), but let me know if that helps keep your connection more stable. And if it fails again, check the status with at!gstatus to see if its in low power mode again.

User avatar
WillTonn
Posts: 25
Joined: Fri Oct 12, 2018 10:09 pm

Re: WG3526 Connection Issues

Post by WillTonn » Wed Oct 31, 2018 8:45 am

What will it say when it is in low power mode? I have done the at!gstatus? command when I lose connection and it does not look any different. Here is when I have good connection:

Code: Select all

at!gstatus?
!GSTATUS: 
Current Time:  1247		Temperature: 41
Reset Counter: 6		Mode:        ONLINE         
System mode:   LTE        	PS state:    Attached     
LTE band:      B25    		LTE bw:      5 MHz   
LTE Rx chan:   8109		LTE Tx chan: 26109
LTE CA state:  NOT ASSIGNED
EMM state:     Registered     	Normal Service 
RRC state:     RRC Connected  
IMS reg state: No Srv  		

PCC RxM RSSI:  -52		RSRP (dBm):  -79
PCC RxD RSSI:  -55		RSRP (dBm):  -82
Tx Power:      0		TAC:         4D10 (19728)
RSRQ (dB):     -11.8		Cell ID:     09A21304 (161616644)
SINR (dB):     21.0


OK

User avatar
WillTonn
Posts: 25
Joined: Fri Oct 12, 2018 10:09 pm

Re: WG3526 Connection Issues

Post by WillTonn » Wed Oct 31, 2018 8:50 am

I was just looking at the modem debug screen and I happened to lose connection and saw this:

Code: Select all

AT!GSTATUS?
!GSTATUS: 
Current Time:  1470		Temperature: 39
Reset Counter: 6		Mode:        LOW POWER MODE 
OK

swwifty
Posts: 414
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: WG3526 Connection Issues

Post by swwifty » Wed Oct 31, 2018 9:05 am

WillTonn wrote:
Wed Oct 31, 2018 8:50 am
I was just looking at the modem debug screen and I happened to lose connection and saw this:

Code: Select all

AT!GSTATUS?
!GSTATUS: 
Current Time:  1470		Temperature: 39
Reset Counter: 6		Mode:        LOW POWER MODE 
OK
Yeah, that's what I'm referring to. I think the modem is going into low power mode for some reason, and dropping your connection.

Has this modem ever worked reliably for you, and stay connected for extended periods of time?

User avatar
WillTonn
Posts: 25
Joined: Fri Oct 12, 2018 10:09 pm

Re: WG3526 Connection Issues

Post by WillTonn » Wed Oct 31, 2018 9:10 am

When I first assembled it it seemed to be working fine that first day or so.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post