WG3526 Connection Issues

Related to Router Devices ONLY
User avatar
WillTonn
Posts: 25
Joined: Fri Oct 12, 2018 10:09 pm

Re: WG3526 Connection Issues

Post by WillTonn » Wed Oct 31, 2018 9:40 am

So the system log screen only shows a recent snippet - is there a way to see a more comprehensive system log? Or a way to set it up so that the system log updates a txt file or something?

swwifty
Posts: 76
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: WG3526 Connection Issues

Post by swwifty » Wed Oct 31, 2018 10:35 am

If you login to the router via ssh, and run the command 'dmesg' you can see more output. Not sure if you know how to do that or not though.

User avatar
WillTonn
Posts: 25
Joined: Fri Oct 12, 2018 10:09 pm

Re: WG3526 Connection Issues

Post by WillTonn » Wed Oct 31, 2018 11:13 am

Should I be concerned about this?

Code: Select all

[46855.830540] usb 1-2: new high-speed USB device number 30 using xhci-mtk
[46855.971158] usb 1-2: config 1 has an invalid interface number: 12 but max is 3
[81573.284415] usb 1-2: config 1 has an invalid interface number: 13 but max is 3
[81573.291713] usb 1-2: config 1 has an invalid interface number: 13 but max is 3
[81573.299130] usb 1-2: config 1 has no interface number 1
[81573.304352] usb 1-2: config 1 has no interface number 2
or this?

Code: Select all

[59405.555523] WARNING: CPU: 1 PID: 8147 at /home/user/openwrt/source-17014/build_dir/target-mipsel_24kc_musl-1.1.16/linux-ramips_mt7621/mt76-2017-10-12-1be430fc/mt7603_mac.c:1279 mt7603_mac_work+0xe8/0x284 [mt7603e]()
[59405.574606] Modules linked in: qcserial pppoe ppp_async option iptable_nat cdc_mbim usb_wwan sierra_net sierra rndis_host qmi_wwan pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 ipt_REJECT ipt_MASQUERADE huawei_cdc_ncm cdc_ncm cdc_ether xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CLASSIFY usbserial usbnet usblp slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack_netlink iptable_mangle iptable_filter ipt_ECN ip_tables crc_ccitt cdc_wdm fuse sch_cake nf_conntrack act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_tbf sch_htb sch_hfsc sch_ingress mt76x2e mt7603e ledtrig_usbport mt76 mac80211 cfg80211 compat xt_set ip_set_list_set ip_set_hash_netiface ip_set_hash_netport ip_set_hash_netnet ip_set_hash_net ip_set_hash_netportnet ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables ifb tun vfat fat hfs nls_utf8 nls_iso8859_1 nls_cp437 usb_storage leds_gpio xhci_mtk xhci_plat_hcd xhci_pci xhci_hcd uhci_hcd ohci_platform ohci_hcd ahci libahci libata ehci_platform ehci_hcd sd_mod scsi_mod gpio_button_hotplug ext4 jbd2 mbcache exfat usbcore nls_base usb_common mii crc32c_generic
[59405.720204] CPU: 1 PID: 8147 Comm: kworker/u8:2 Tainted: G        W       4.4.92 #0
I downloaded Mobaxterm but it looks like dmesg brings up the kernel log and not the system log. Thanks for your help by the way.

swwifty
Posts: 76
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: WG3526 Connection Issues

Post by swwifty » Wed Oct 31, 2018 12:12 pm

oh, that's interesting. It looks like init or systemd is crashing (in the second code output you pasted).

Do you have any other hardware you could try this sim card in? I'm beginning to suspect there might be a hardware issue with your router and/or modem.

User avatar
WillTonn
Posts: 25
Joined: Fri Oct 12, 2018 10:09 pm

Re: WG3526 Connection Issues

Post by WillTonn » Wed Oct 31, 2018 12:14 pm

Just the r850 hotspot that came with the sim card. I had it back in the hotspot a week or so ago to check the apn settings and it works great in the hotspot.

swwifty
Posts: 76
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: WG3526 Connection Issues

Post by swwifty » Wed Oct 31, 2018 1:00 pm

WillTonn wrote:
Wed Oct 31, 2018 12:14 pm
Just the r850 hotspot that came with the sim card. I had it back in the hotspot a week or so ago to check the apn settings and it works great in the hotspot.
so no connection dropping issues with the hotspot, and just to clarify thats a completely separate hardware device? Only shared piece is the sim card?

User avatar
WillTonn
Posts: 25
Joined: Fri Oct 12, 2018 10:09 pm

Re: WG3526 Connection Issues

Post by WillTonn » Wed Oct 31, 2018 1:20 pm

That is correct.

swwifty
Posts: 76
Joined: Thu Aug 30, 2018 8:21 pm
Location: NE GA Mountains

Re: WG3526 Connection Issues

Post by swwifty » Wed Oct 31, 2018 1:33 pm

WillTonn wrote:
Wed Oct 31, 2018 1:20 pm
That is correct.
I'd be inclined to believe at this point there is more than likely a hardware issue with your router or modem. I'm leaning towards the modem due to it going into low power mode all the time. Can you get a replacement for it , and see what happens?

User avatar
JimHelms
Site Admin
Posts: 274
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: WG3526 Connection Issues

Post by JimHelms » Sun Nov 11, 2018 7:34 am

WillTonn wrote:
Wed Oct 31, 2018 9:40 am
So the system log screen only shows a recent snippet - is there a way to see a more comprehensive system log? Or a way to set it up so that the system log updates a txt file or something?
Connecting Logging.png
You do not have the required permissions to view the files attached to this post.

User avatar
JimHelms
Site Admin
Posts: 274
Joined: Tue Dec 19, 2017 8:59 pm
Location: DFW Texas
Contact:

Re: WG3526 Connection Issues

Post by JimHelms » Sun Nov 11, 2018 7:39 am

WillTonn wrote:
Wed Oct 31, 2018 8:50 am
I was just looking at the modem debug screen and I happened to lose connection and saw this:

Code: Select all

AT!GSTATUS?
!GSTATUS: 
Current Time:  1470		Temperature: 39
Reset Counter: 6		Mode:        LOW POWER MODE 
OK
Try THIS mod to Connection Monitoring.

Post Reply