Hotspot Bypass not registering with custom TTL rules

Related to Router Devices ONLY
Forum rules
Use the SEARCH function for related issues PRIOR to posting for assistance.
Cainmos
Posts: 8
Joined: Thu Aug 13, 2020 6:58 am
Has thanked: 1 time
Been thanked: 0

Hotspot Bypass not registering with custom TTL rules

Post by Cainmos » Sun Sep 13, 2020 1:30 pm

Hopefully some of you more technical people can help get hotspot bypass working for my setup.

Since I am traveling this is my setup to keep it simple:
Samsung A71 5G with AT&T Unlimited Elite post paid plan which is tethered to a GLiNet AR750S.

Before getting this I had read a thread on here that USB tethering is the way to go for unlimited data on ATT now but am having trouble getting it to register as just my unlimited data and not hotspot data.

In the advanced settings under the firewall for custom rules I have the following TTL settings which seems to be working:

#start TTL rules
iptables -t mangle -I POSTROUTING -o usb0 -j TTL --ttl-set 65
iptables -t mangle -I PREROUTING -i usb0 -j TTL --ttl-set 65
ip6tables -t mangle -A POSTROUTING -o usb0 -j HL --hl-set 65
ip6tables -t mangle -I PREROUTING -i usb0 -j HL --hl-set 65
#end TTL rules

When I ping google or other addresses I see a TTL of 64 (at least on my laptop hardwired to the router) but when I ping myself I get TTL 128. Before applying the custom rule and pinging google I would get a TTL of 112 displayed.

Any suggestions would be appreciated. I read someone mention BillA's Tethering guide but I can't find it with search. I'm happy to read and learn if I can at least get set onto the correct path.

Cainmos
Posts: 8
Joined: Thu Aug 13, 2020 6:58 am
Has thanked: 1 time
Been thanked: 0

Re: Hotspot Bypass not registering with custom TTL rules

Post by Cainmos » Mon Sep 14, 2020 12:35 pm

So I found Bill's guide after some more searching. It seems that TTL number changes don't matter or are not being applied correctly. I have tried 64, 65, 66, and 117 so far.

Next stop is to try flashing with GoldenOrb.

I did notice that the phone requests tethering permissions prior to it being enabled. It is not able to do this if I try using a VPN and it errors for setting up tethering to the router. Does anyone know if newer ATT phones bypass forced TTL settings and flag all data throughput as tethered no matter what?

RockyinNM
Posts: 86
Joined: Thu Mar 07, 2019 8:35 am
Location: Hills of TN
Has thanked: 32 times
Been thanked: 18 times

Re: Hotspot Bypass not registering with custom TTL rules

Post by RockyinNM » Mon Sep 14, 2020 4:00 pm

Hello all, still working on my custom TTL settings--I use hotspot data on my win 10 laptop, but NOT on my older win 7??

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
iptables -t mangle -I POSTROUTING -o wwan0 -j TTL --ttl-set 117
iptables -t mangle -I PREROUTING -i wwan0 -j TTL --ttl-set 117

I thought I had this fixed awhile back-not
any suggestions, this is a 826 T2

Here are my DNS settings--
under modem tab-

Custom DNS Server1 :
1.1.1.1

Custom DNS Server2 :
1.0.0.1

Custom DNS Server3 :
2606:4700:4700::1111

Custom DNS Server4 :
2606:4700:4700::1001
Enable Connection Logging

here are my settings under the Network tab-

Status
Device: br-lan
Uptime: 8h 53m 44s
MAC: 78:A3:51:59:FB:B4
RX: 19.85 MB (280348 Pkts.)
TX: 948.04 MB (682094 Pkts.)
IPv4: 192.168.1.1/24
IPv6: fd8b:abcf:cea8::1/60
Protocol
Static address
IPv4 address
192.168.1.1
IPv4 netmask
255.255.255.0
IPv4 gateway
IPv4 broadcast
Use custom DNS servers
1.1.1.1

1.0.0.1


Thanks, Rocky

RockyinNM
Posts: 86
Joined: Thu Mar 07, 2019 8:35 am
Location: Hills of TN
Has thanked: 32 times
Been thanked: 18 times

Re: Hotspot Bypass not registering with custom TTL rules

Post by RockyinNM » Mon Sep 14, 2020 5:58 pm

So I found Bill's guide after some more searching.

would you please share the link to (Bill's guide)I need all the help I can get-lol thanks

Cainmos
Posts: 8
Joined: Thu Aug 13, 2020 6:58 am
Has thanked: 1 time
Been thanked: 0

Re: Hotspot Bypass not registering with custom TTL rules

Post by Cainmos » Tue Sep 15, 2020 5:12 pm

RockyinNM wrote:
Mon Sep 14, 2020 5:58 pm
So I found Bill's guide after some more searching.

would you please share the link to (Bill's guide)I need all the help I can get-lol thanks
viewtopic.php?f=22&t=1337&p=10303&hilit ... ing#p10303

RockyinNM
Posts: 86
Joined: Thu Mar 07, 2019 8:35 am
Location: Hills of TN
Has thanked: 32 times
Been thanked: 18 times

Re: Hotspot Bypass not registering with custom TTL rules

Post by RockyinNM » Tue Sep 15, 2020 7:37 pm

Thank you for sharing that link, some great knowledge there.
thanks, Billa :)

Time-Pilot
Posts: 11
Joined: Mon Aug 17, 2020 11:12 am
Has thanked: 1 time
Been thanked: 3 times

Re: Hotspot Bypass not registering with custom TTL rules

Post by Time-Pilot » Wed Sep 16, 2020 10:22 pm

So a lot of phones are snitches and TTL settings won't hide your tethering.

EasyTether will hide it.

Cainmos
Posts: 8
Joined: Thu Aug 13, 2020 6:58 am
Has thanked: 1 time
Been thanked: 0

Re: Hotspot Bypass not registering with custom TTL rules

Post by Cainmos » Fri Sep 18, 2020 6:22 pm

Time-Pilot wrote:
Wed Sep 16, 2020 10:22 pm
So a lot of phones are snitches and TTL settings won't hide your tethering.

EasyTether will hide it.
Thank you for the suggestion. It does appear that the ATT supplied Samsung A71 snitches and requests tethering. It would be nice to know if anyone has an unlocked version direct from Samsung that does/doesn't since it wouldn't have carrier bloat.

Was able to get back to service and get easytether pro installed and it now seems to be masking the tether request. It was fairly easy to get setup on the GLinet AR750s.

Happy to be able to use my unlimited data on my laptop/secondary devices and work more easily now.

St1300
Posts: 6
Joined: Sat Sep 12, 2020 1:30 pm
Has thanked: 2 times
Been thanked: 0

Re: Hotspot Bypass not registering with custom TTL rules

Post by St1300 » Sat Sep 19, 2020 3:58 am

How did you get easytether pro to work on your phone ? Did you only use the app and the GL-AR750 with firewall settings or did you use this method in the blog below ?
https://blog.gl-inet.com/how-to-tether- ... asytether/

Cainmos
Posts: 8
Joined: Thu Aug 13, 2020 6:58 am
Has thanked: 1 time
Been thanked: 0

Re: Hotspot Bypass not registering with custom TTL rules

Post by Cainmos » Fri Sep 25, 2020 7:10 pm

St1300 wrote:
Sat Sep 19, 2020 3:58 am
How did you get easytether pro to work on your phone ? Did you only use the app and the GL-AR750 with firewall settings or did you use this method in the blog below ?
https://blog.gl-inet.com/how-to-tether- ... asytether/
I used the link you posted and it initially worked great. I have been out of cell service for about a week and coming back to it I'm now having an issue with the router. It is trying to configure it as a modem instead of USB tethering when connecting the phone. I'm not sure if it is because of easytether or not. At the moment I'm not sure how to fix it.

Post Reply